Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Fleshcult

Take the role of an incubus or succubus. Seduce mortals into your lair · By Oneirolith

"An error occured while updating Fleshcult (missing executable)"

A topic by diedcute created Oct 28, 2020 Views: 329 Replies: 16
Viewing posts 1 to 4

So Im having issues getting this game to run, as the executable keeps getting deleted I believe. However, Ive uninstalled all my antivirus and cleaned it out with avast antivirus cleaner, so it shouldnt be giving me any issues, along with windows defender is turned off. Any ideas? Im currently repairing my steam content folders to see if that helps but its taking a awful long time.

(1 edit)

Also tried installing the itch.io version, the application stays however it closes immediately with these logs:

[Fleshcult] CEF Python 66.0
[Fleshcult] Chromium 66.0.3359.181
[Fleshcult] CEF 3.3359.1774.gd49d25f
[Fleshcult] Python 2.7.13 32bit
[Fleshcult] Working directory: C:\Users\Squalo\Desktop\fleshcult


*Nevermind, the executable is gone again.

Developer

That's a weird one! There's no updater in fleshcult itself, and the only code I wrote that handles deletion is for save files, so I can't think of anything it could be doing to nuke itself like that. If you're seeing exes vanish both in Steam and Itch it sure seems like there's some third party at work. Are they winding up in Avast's quarantine or something?

It might've had trouble starting because there are two executables involved: fleshcult.exe, which has the game logic, and subprocess.exe which has a browser engine that displays the game. If subprocess.exe got eaten, it won't be able to start.


Yeah these are the only files I have, and like I mentioned I completely uninstalled Avast, along with using Avast's cleaner that gets rid of anything avast-related (and restarted) and its still deleting for no reason :<  So theres no way I can even check, since I dont have avast anymore. 

Developer (1 edit)

Well, there's still Windows Defender, which is built into windows. Apologies if you've already been through this, but you can check what it's been up to by opening up:
Settings -> Update & Security -> Windows Security -> Virus & Threat Protection -> Protection History

(1 edit)

Theres nothing in it. Though now when I try to download the zip file itself, it keeps deleting the zip file now, but it doesnt show up in recent protection.

(1 edit)

Okay, found a old zip file I could unpack. I tried starting it this time, and the exe stayed along with the manifest, though it closes immediately still.

These are the debug logs:

[1027/133617.430:ERROR:main_delegate.cc(710)] Could not load locale pak for en-US
[1027/133617.431:ERROR:main_delegate.cc(717)] Could not load cef.pak
[1027/133617.431:ERROR:main_delegate.cc(734)] Could not load cef_100_percent.pak
[1027/133617.431:ERROR:main_delegate.cc(743)] Could not load cef_200_percent.pak
[1027/133617.431:ERROR:main_delegate.cc(753)] Could not load cef_extensions.pak
[1027/133617.448:ERROR:content_client.cc(272)] No data resource available for id 101
[1027/134031.006:ERROR:main_delegate.cc(710)] Could not load locale pak for en-US
[1027/134031.006:ERROR:main_delegate.cc(717)] Could not load cef.pak
[1027/134031.007:ERROR:main_delegate.cc(734)] Could not load cef_100_percent.pak
[1027/134031.007:ERROR:main_delegate.cc(743)] Could not load cef_200_percent.pak
[1027/134031.007:ERROR:main_delegate.cc(753)] Could not load cef_extensions.pak
[1027/134031.023:ERROR:content_client.cc(272)] No data resource available for id 101


**Edit, the exe is gone now. Idk when it disappeared but its gone. the manifest stayed though.

Developer

The debug logs from the old version are consistent a bug where it can't handle weird characters or underscores in the install path or windows AppData path.

If you click on the notification speech bubble on the taskbar, there's nothing from windows saying "hey, just deleted a bunch of weird exes"? (assuming Windows 10). Is "Reputation Based Protection" turned on? It's in App & Browser Control.

You're not alone, somebody on Steam's getting exe deletion too. Could I get a whole bunch of details off you and I'll see if I can find any commonalities:

  • Windows version
  • Browser you used to download it
  • Browser extensions
  • Zip program used to extract it
  • Anything else you can think of that might have a penchant for deleting exes

It doesnt say anything about deleting anything, though when I do download the zip file (from itch.io) it always prompts me that its not commonly downloaded and may be dangerous (which i go through with anyways) and then it immediately says download error.

Windows Version: 10

Browser: Chrome AND Microsoft Edge

Browser Extension: Chrome has only adblocker.

Zip: Winrar

Im not too sure what else to really put, since Im at a lost on whats not letting me play this. Kinda fustrating, as I turned off my firewall, disabled antivirus, disabled about everything tbh. Just doesnt want to stay.

Developer (2 edits)

I've made a new beta version on Steam, which I understand you've also got. It gets rid of some data compression inside the executable, which I hear antivirus programs don't like.

If you have any patience left for all this nonsense, I'd be interested to hear if the computer poltergeist eats this one. (Right click on game, properties, betas, opt into the beta called "beta")

P.S. I strongly recommend turning your firewall back on!

Just reinstalled while on the beta, and it just seems to continously re-download the executable, deletes itself, re-downloads executable, deletes itself, over and over again. So no dice :c I really have no idea where its going at all at this point.

https://i.gyazo.com/d20645a60dd17d15eb0bfa893f510a96.mp4

I made a gif showing what happens

Developer

This is a lot to ask, but if you're feeling particularly intrepid you could try bringing out the big guns: Microsoft's SysInternals page has a program called Process Monitor. It makes a huge log of which program did what while it's running.

https://docs.microsoft.com/en-us/sysinternals/

If you run it (procmon.exe), it'll start up by showing a list of filters. Here's a page showing how to add a filter for file deletions.
https://mikeberggren.com/post/135351739546/procmon-delete

If add that and hit ok, then try to install Fleshcult in Steam, you might see an entry in the big list for something deleting fleshcult (and probably a ton of unrelated deletions besides). By double clicking on the entry you can find out lots of stuff about that program and what it thought it was doing.

This is what it gives me.

Developer

Looks like that event is just Steam deleting a temporary file that was used for the download, after copying the exe into its final location in SteamApps/common/Fleshcult/fleshcult.exe. If there's no deletion from that final location, that suggests that Steam couldn't write the file there in the first place.

To get a broader picture we could try removing the filter for deletions and replacing it with
Path   Contains   fleshcult.exe   then Include

Install fleshcult yet again and wait for it to get deleted again, and you'll get pages and pages of events. You could save the log as a spreadsheet and send them to me. To do that, go to File -> Save... and pick Events Displayed Using Current Filter and Comma-Separated Values and hit OK. If you could email it to me at jack@fleshcult.com I'll pore over it and compare it to what happens on my computer.

Dang, it's really crazy that this is necessary. I feel gaslit and I'm not even the one that it's happening to!