Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Twilight-Shimmer

3
Posts
A member registered Mar 04, 2018

Recent community posts

that explains why i wont be able to play it heh. I am on VISTA

what are teh system requirements to play? I am on an older OS and it wont play in any of my browsers.

This is a very interesting and cute game. May I offer a few suggestions though? Since you can (and do) work a job in the game add in a money system so you actually have to buy the other diapers if you want them. I also look forward to being able to actually take the modeling job at the diaper store lol. I hope this game sees updates in the future