Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Linux version won't start.

~/Downloads/the-ferryman-linux$ ./ferryman.x86_64 
./ferryman.x86_64: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./ferryman.x86_64)


It seems the latest Ubuntu 18.04.2 LTS uses older lib.

 apt-cache policy libc6
libc6:
  Installed: 2.27-3ubuntu1
  Candidate: 2.27-3ubuntu1
  Version table:
 *** 2.27-3ubuntu1 500
        500 http://hu.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status

Thanks for your report, I will look into it and see if I can provide an alternative build which links against 2.27.

I could reproduce your report in a Ubuntu 18.04 VM which I then used to compile a new export template. For me this fixes the issue as I was able to run the game when bundled with this template. I gave uploaded it separately, the file is named the-ferryman-linux-ubuntu-18-04.zip. Please give it a try and see if you as well can now run the game.

I can confirm that. The new build runs. Thank you.

Pretty nice game. Nice work.

Great, that's reassuring to hear. Thanks again for your report and your kind words, very appreciated!