Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Bug report!

Script error, "friendly.pk3:friendly_zscript/ui.txt" line 1774:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 36:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 36:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 132:
Invalid statement

Execution could not continue.

4 errors while parsing DECORATE scripts


This was when I tried to load the pk3 my dragging and dropping it onto gzdoom.exe. I'm on Windows 10 64-bit and using GZDoom v3.7.2 Modern 64-bit. I've tested with both Ultimate Doom and Doom 2 and the error shows up for both.

This was happening due to a bug in the GZDoom 3.7 series. Try running with the just-released GZDoom 4.0: https://forum.zdoom.org/viewtopic.php?f=1&t=64188

Yep, it's fine now! Haha, remarkable timing there, eh?

Oh crap, new bug. The game crashes whenever I try to load Doom 2 MAP16.


VM execution aborted: array access out of bounds. Max.index = 778, current index = 2491

Called from FriendlyMapCompat.HideLine at friendly.pk3:friendly_zscript/mapcompat.txt, line 36
Called from FriendlyMapCompat.RunMapCompat at friendly.pk3:friendly_zscript/mapcompat.txt, line 29
Called from FriendlyHandler.WorldLoaded at friendly.pk3:friendly_zscript/handler.txt, line 365


That's the only map I've seen with this error so far.

Build 68 should have a fix for that.