Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

I am on PC, there is an error message of "Can't create a OpenGL 3.3 Rendering Context" followed by another message immideiatly after saying "Your system's graphic drivers seem not to support OpenGL 3.3/OpenGL ES 3.0, sorry. :( Godot Engine will self-destruct as soon as you anknowledge this error message" I'm not super sure what details I need to send, but my laptop is a five years old or so samsung, with pretty much everything standard still in place aside from a replaced hard drive.

Please try to update your graphic card's driver. You can also e-mail support@itch.io and request a refund.

Hope this will work ! And again, I'm sorry for this mishap Calliope !

The driver unfortunately appears to already be in it's most updated state. I tried to make it update via the device manager and it said that the current driver was already installed.