Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Yeah LÖVE isn't compatible across versions. You'll need to install and use LÖVE 0.10.2, as the error screen suggests, or use one of the pre-built standalone versions.

Also version 11 changed a lot of fundamental stuff, and converting a game from 0.10 to 11 is a straightforward but nontrivial process.