Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Just wanted to let you know after trying to run your game, it appears it is not compatible with the newest version of LOVE 11.1. I received the following error...

This game indicates it was made for version '0.10.2' of LOVE.
It may not be compatible with the running version (11.1).
LOVE - Warning: main.lua:63: Using deprecated function love.filesystem.isFile (replaced by love.filesystem.getInfo)
Error: neonphase/scenes/title.lua:21: bad argument #2 to 'newSource' (string expected, got no value)
stack traceback:
    vendor/hump/gamestate.lua:89: in function 'handler'
    [string "boot.lua"]:637: in function <[string "boot.lua"]:633>
    [C]: in function 'newSource'
    neonphase/scenes/title.lua:21: in function 'init'
    klinklang/object.lua:11: in function 'TitleScene'
    main.lua:124: in function 'load'
    [string "boot.lua"]:488: in function <[string "boot.lua"]:487>
    [C]: in function 'xpcall'
    [string "boot.lua"]:650: in function <[string "boot.lua"]:639>
    [C]: in function 'xpcall'

Yeah LÖVE isn't compatible across versions. You'll need to install and use LÖVE 0.10.2, as the error screen suggests, or use one of the pre-built standalone versions.

Also version 11 changed a lot of fundamental stuff, and converting a game from 0.10 to 11 is a straightforward but nontrivial process.