Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

You need LÖVE ; the game won't work with vanilla Lua.  LÖVE is the game engine / runtime it runs on.  It's a small download from https://love2d.org/ or probably installable via your distro if you're on Linux.