🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Majalis, I cross-referenced the engine you are using for the game and the issue appears to be that the engine requires OpenGL 2.0 support. I do not think there is anything you can do about this particular issue. A lot of older computers that could run the game will not be able to because of how slipshod OpenGL support was ~8-10 years ago.  One can assume any computer made during the early Win 7 era and newer should not have an issue, but computers made during the XP/Vista era may only support OpenGL 1.4 or 1.5, preventing those rigs from running the game despite meeting all other system requirements.

Yes, this is definitely true, although this isn't the error we've seen on rigs that lack OpenGL 2.0 support in the past.