Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Oh, that is curious. Are you running from an Ubuntu-based distro?

I was running from an Ubuntu-based distro (Linux Mint) and I had this problem. My workaround was just downloading the browser version. Someone in the comments below linked the downloads to libcrypto and libssl but it told me I had the wrong ELFCLASS still.

(+1)

Thanks everyone for reporting this! To properly fix it,  I'll probably need to update the game engine to the latest version. It could still take some time before I get around to properly fixing this issue, but I'll look into this sooner or later (and like you noted, you can use the browser version as well).