Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

still same error ;-; , i guess my system is low-end. well its true IT IS LOW-END.

(+1)

I'm sorry that the problem is persistent, but thanks for waiting! 

I think the issue is that the game needs OpenGL 3 or OpenGL 2 to run, but (according to my research) Intel 82945G integrated graphics doesn't support either of them. (Totally not your fault!)

So, if you're still interested in the game, check out this page tomorrow. I'll upload a version to play in the browser. 

:)