Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

any chances for devolved Unity 5.6 version? this doesn't really need latest Unity does it?

Yup, sorry, you need latest Unity version.

k, no problem, keep up the great work!