Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
(+3)

Will the newer OSX versions be supported in future? Because the only thing that keeps me away from buying it is, that my OSX version is not supported.

(1 edit)

Agreed, are there plans to update for this?

We're not planning to officially support newer OSX versions, but I've heard reports from some users that it works just fine on them.