🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles
(Edited 1 time)

I cant help you with a solution because I have exactly the same problem. However I dont think its got anything to do with Freerider. I , like you can get the transmitter to bind with the dongle but in any sim I try (DRL,Velocidrone) the result is excatly the same as you describe , only one axis seems to be recognised. I tried the dongle with an old Spektrum Dx4 transmitter I have and it works fine so its something to do with the Orange Tx and the dongle but I cant work out what! They do recommend that you have your transmitter set to HELI but didnt make any difference for me.

Thanks for replying and glad to know that I am not the only one out there with this issue. Spent hours trying to resolve to no avail. All I wanted to do is practice on a drone simulator and had no idea it would be this difficult. I agree this has NOTHING to do with Freerider but some quirky setup on computer I am sure. Sorry that you are facing the same. I guess I will have to see if I can return the dongle as right now it is not useable and look into purchasing a simulator transmitter that should work.

I appreciate your time.

Have a great week.

Mark

Your welcome. I've ordered a cable off eBay to see if that works with the transmitter as I'd rather use the Orange one as opposed to the DX4 but slightly disappointing that the dongle doesn't appear to work with a transmitter from the same manufacturer ! I was hoping it might be something simple but I've tried all I can think of to no avail!


Paul