Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

I get this when I run the game with love version 11.1 (it’s not the version you made the game with, but it’s the default version for my debian system)

Error

Shield.lua:10: Could not decode file ‘assets/sprites/shield.png’ to ImageData: unsupported file format

Traceback

[C]: in function ‘newImage’ Shield.lua:10: in main chunk [C]: in function ‘require’ Character.lua:8: in main chunk [C]: in function ‘require’ collision.lua:2: in main chunk [C]: in function ‘require’ main.lua:30: in main chunk [C]: in function ‘require’ [C]: in function ‘xpcall’ [C]: in function ‘xpcall’

yeah it's built with version 0.10.1 so it won't work with the new API. I think you would need to run it on an older version of love2d to make it work on Linux.