πŸ€‘ Indie game storeπŸ™Œ Free gamesπŸ˜‚ Fun games😨 Horror games
πŸ‘· Game development🎨 AssetsπŸ“š Comics
πŸŽ‰ Sales🎁 Bundles
A jam entry

B@TTYView game page »

A 2D Batformer.
Submitted by sjl (@stevelosh) with 4 hours, 40 minutes before the deadline

Play game

Visit B@TTY's game page

Results

CriteriaRankScore*Raw score
Theme Integration#32.8284.000
Presentation#32.8284.000
Creativity#42.1213.000
Entertainment#41.4142.000
Overall#42.2983.250

Ranked from 1 rating. Score is adjusted from raw score by the median number of ratings per game in the jam.

Leave a comment

Log in with your itch.io account to leave a comment.

Comments

Nice idea of being a bat having some kind of echo visor.

Looks like a real game, nice music, a title screen with explanations, echos look very good, but multiple echos at once don't work nicely.

Just the same all the time, there seems to be no goal, it's confusing, that you warp around (probably the world moves),

The idea matches the theme very well. The music and general atmosphere could be a bit darker.

Developer

The code is at https://github.com/sjl/batty -- I committed some instructions and bug fixes so it should run.  Maybe.  I don't know, deployment in Common Lisp is still a shitshow in This, The Year of Our Lord 2017.  I don't really need ratings, it was just an experiment, don't worry if you can't run it.

Developer

I pushed a new MacOS version.  Maybe it'll work, I don't know.

Add install instructions.

I have no idea how to install this. I don't even know, which language this is written in, or where the source code is.

(Edited 2 times)

It's a mac binary, but the game is written in Common Lisp, and the source can be found here. I couldn't make it run on Windows however, because of dependency issues. Also, the binary doesn't run on Mac: it crashes on startup.

I get this error:

```

Error while trying to load definition for system batty from
pathname
/home/porky11/quicklisp/local-projects/batty/batty.asd:
   Component :DEPLOY not found, required by NIL

```

Seems, this repo is not in quicklisp. Where can I find it?