Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Character Creator 2D

Character creation and customization tool · By mochakingup

PNG Export not working with v.1.70

A topic by munichorn created Jul 28, 2020 Views: 194 Replies: 13
Viewing posts 1 to 8

I just bought CC 2D v. 1.70. I work with the standalone version on Windows 10 Home. My problem is that the PNG Export does not work correctly. When I click on Export for the first time, all looks ok and I can save the character as PNG. But if I choose an option (Portrait, Full Body etc.), the picture itself disappears from the preview and I can only export the background, either transparent or colored. It stays this way if I try to export later w/o restarting CC.

Developer

Hey, thanks for reporting this! We'll take a look immediately! 

Developer

Hi, after a quick test, we can't seem to replicate the issue. Everything works as it should on our end.

Can you provide us with a complete step by step of what you do to trigger this?  

Also, screenshots on what it looks like would be extremely helpful.

I have the same issue! Please check this bug!


Best regards

Developer

Hi there!

We still can't reproduce the issue.

Can you provide us a step by step on how to reproduce this?

Screenshots when this happen would also be extremely helpful!

Hi there!

It's just like munichorn already wrote, when I click on the "Export PNG" Button, everything looks fine, but as soon as I click on "Portrait", Full Body" or something else from within the CONFIG PRESET section, the character disappears. Also it seems, as if Custom Presets are not saved properly.

There is a big bug in there, maybe you should try to reproduce it on an isolated, fresh system. Since we both have this issue, I am sure there are more people with this problem. Of course I can send you a video, but how?

Best regards and thanks for the quick reply!

Developer (2 edits)

Yeah I've tried on a fresh system and still can't reproduce the issue, that's why we're stumped. So far these two are the only reports of this particular bug, we're still trying to figure out what causes this.

You can upload it somewhere, cloud or youtube, and paste the link here. That would be the easiest, I think. Or you can send it to our email contact @ simpleton . rocks

edit:

Follow up questions, if you don't mind. Were you able to save and load your own custom presets? Or is it also showing the same issue?

(2 edits)

Okay, I played a bit around today...seems as if something is going wrong in the CHARACTER ADJUSTMENTS. 

1. Start CC2

2. Loading my Character

3. Clicking on "Export PNG"

4. Character appears

5. Now when choosing my own preset, the character is gone. BUT if I play with the sliders under the CHARACTER ADJUSTMENTS (SCALE, OFFSET X, OFFSET Y) the character comes back into the viewport.

6. Also, the Values SCALE, OFFSET X, OFFSET Y only work properly, if I move the sliders with the mouse. Typing in values and pressing ENTER always kicks my character out of the viewport.

Hopefully that helps!

Best regards

Developer

Hey, thanks for the additional info!

In those values, which decimal point symbol are used? is it using dot or comma?

I was suspecting it has something to do with regional settings, where other symbol is used instead of dot in decimal point.

But I've tried changing my regional settings and it still works as expected, so I'm not so sure anymore.

Hi, I tested my version of CC 2D on Windows 7 and I got still the same problem, see the screenshots: https://c.gmx.net/@328090593659984504/c9tHBMdASl6WkqcKl_8SQA

Developer

Hey, thank you so much for this!

My main suspicion right now, is the different decimal symbol.

So value that is supposedly 0.15 became 15 instead. 

Does your computer use language where the decimal symbol is not dot? 

Yes, in both cases it was a non-English Windows version, where the decimal dot is represented by the comma. So your hypothesis would fit.

Developer

alright, I think I've found a fix for this.

I need to do a couple more tests,  but if nothing goes wrong, it should be in the next update!

Thanks, now it works fine!