Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

MasterPlan

Indie Project Planning Ideaboard · By SolarLune

[SOLVED] Suggestion - Clipboard integration

A topic by Zeean created Jul 13, 2020 Views: 111 Replies: 3
Viewing posts 1 to 4
(3 edits) (+1)

I have picked up MasterPlan as of today as a less heavy version of Miroboard which it works quite nicely. 

My only suggestion being: Allow text be copied and pasted in and out of MasterPlan.

Haven't found this mentioned anywhere else or if clipboard is meant to be working with MasterPlan (I have been using it on Ubuntu).

Thanks.

Edit: I noticed finally there is paste content option in the menu but it fails to paste plain text into a task, doesn't appear in the log or running the software from the terminal the exact reason for this failure. Never the less, being able use clipboard keyboard shortcuts would be the best solution for this.

(4 edits) (+1)

Yo! Thanks a ton for picking up MasterPlan! I really appreciate it, especially if you have another tool that you were already using.

The clipboard is indeed fully supported for copying and pasting text into and out of MasterPlan on all platforms. It requires an external clipboard package to be installed to work on Ubuntu / Linux, though. Do you have xsel, xclip, or wl-clipboard installed? I thought I remember checking and seeing that one of those should be installed by default on the latest version of Ubuntu.

As for the lack of an error, it's not reporting the error currently as I just now noticed that I am suppressing it; apologies! I didn't really consider why one might not be able to read from the system clipboard. If you do have one of those tools installed and it's still not working (Ctrl+C, Ctrl+V to copy and paste text, just like usual), I'll redirect the error to the log and put out a hotfix build so we can hopefully see exactly what the issue is.

Thank you SolarLune for responding so quickly.

I had a look at what packages are installed in Ubuntu 20.04 LTS. None of those packages you mentioned were installed by default. I installed xclip and now copying & pasting works. Thank you very much for that, I wouldn't have picked up on that being the issue.

Ah, I thought it included one of those - my mistake!