Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

COMP/CON

A digital toolset for the LANCER TTRPG · By Massif Press, beeftime

UNCLE requires superheavy mount?

A topic by Gyraxis created Jul 10, 2020 Views: 204 Replies: 2
Viewing posts 1 to 3

One of my players brought this up while building their crazy aux build, but the UNCLE says it requires a superheavy mount in the COMP/CON. Is this intentional?

Developer(+1)

I think maybe they misread the detail -- UNCLE is restricted on Superheavy mounts, not required.

Huh ok. Guess it was a weird addition since the thing already specifies what mounts UNCLE can use. Seems kinda unnecessary.