Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Pendula Swing: The Complete Journey

A point & click adventure game set in a fantasy version of the American Roaring 1920s 路 By Valiant Game Studio

Unable to Download

A topic by thedahlingdarling created Jun 06, 2020 Views: 749 Replies: 16
Viewing posts 1 to 14
(2 edits) (+2)

I obtained this as part of the racial justice bundle but the download link says there are no valid files I can access. 



EDIT: It was pointed out below If you download it from the browser page sent to you via e-mail it will work and you just need to install it manually from there. The issue only seems to be when trying to download it via the application's browser. But I was able to download it without a problem through my normal web browser (firefox in this case) so try that first and if it still does not work you may have to contact itch.io support. 

I have the same problem

I unfortunately have also not been able to download this so far.

same

Yup, also same.

Shame because I remember playing the demo/chapter 1 on steam ages ago and was happy to see it here in the bundle.. =(

(+1)

I just tried it and it works for me! I have a PC, if that makes any difference - I downloaded it from the link from my itch.io library after I purchased the bundle there, and extracted it first before running it. Hope that helps! 

Developer

So sorry! That is strange! Looking into it - thank you so much for your patience!

Oh interesting, 'ohmygawditsburning' is correct, from the email link to the games collection it is indeed downloadable (Page 21 of the list, unless it's randomized for everyone)

From the client itself or searching your collections manually it isn't however. Strange.

Downloading now :D

Developer(+1)

We looked into this and there is nothing we can fix. If you continue to have problems with the downloads, please kindly contact the support for Itch. I hope it won't be the case though as I am sure the have a lot to do rn! 

(+1)

Thank you for touching base! I tried what "ohmygawditsburning" said and that did work. So the download is there it just wont work though the application only through the browser which tbh is a non issue adfkj so we're all good here. I'll update my original post with the information so anyone with the same issue will know what's going on. 

I had this issue yesterday, but I'm currently downloading it, so it seems solved.

Double interesting, the dev claims nothing changed on their end but it is indeed downloading straight from the client now. Perhaps an itch.io problem itself which was fixed on their end? I imagine their whole servers are still being inundated :)

It's now working from the client for me, too. Yaaay!

Developer(+1)

Happy to hear that it seems to be working now 馃槉 Hope you enjoy the game! 

(1 edit)

Not working for me and not sure how to resolve, i download the file, extract it, and the final result i get from extracting it is a file called ''steam_api64.dll'' (type , application extension)
Im not entirely sure what to do?

Developer

Hello Palastrix, this is so weird... We've looked into it, and can't see what could be the issue. Have you tried downloading the file again? Which program are you using to extract the files?

Hello there, i am using winrar to extract my files,  i've re-downloaded this 3 times, and extracted it, and each time it's always extracted into this Steam.api file. :(