Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

City Clickers

Quintessential SimCity Clone But Not Really · By Eigen Lenk

[Bug]Appraisal and Crashing

A topic by Burylown created May 06, 2017 Views: 378 Replies: 7
Viewing posts 1 to 7

I would just like to personally thank the Developer for working on this game. It's unlike any clicker game out there as well as being quite revolutionary.


Fantastic game, albiet the crashing I have every 15 minutes or so. Keep up the good work! It's amazing.


As for the crashing, I'm not sure if it's a memory leak or what, but it doesn't seem to matter what I do, but after a certain period of time the game just hard crashes.

Developer (3 edits) (+1)

Thank you! That is a really weird bug that's popping up for some players. Could be a memory leak indeed. It's interesting that it's around 15 minutes for everybody who gets this crash (I don't). I will try and get my older laptop running tomorrow just to test it out on a different machine and see if I can get it to crash.

What sort of machine are you running this on? What version of Windows, how much RAM and what graphics card/built-in chip do you have? And is the post-processing effect enabled by any chance? And if you can, please tell me how much memory the game is using according to Task Manager when you play.

(2 edits)

I will do all of this, gimme just a sec and I'll post everything I can.


Edit: Done. However when I tried it on my desktop, Norton picked it up as Sonar.DROPPER, for malware?

Edit 2: I bypassed the firewall for the game, never crashed once on me in the whole hour I played it on my desktop. So it's a problem with Laptops?

Deleted post
(5 edits)

Specs of my laptop are as following (Testing of game crashing will be in a few minutes once I post this):

(Laptop by the way) Asus

>Windows 10 Home Version 1607, 64-Bit OS W/ touchscreen support

>6.00 GB DDR3 RAM

>Display Adapter is actually a Intel(R) HD G520

>CPU is Intel Core i5-6200U @ 2.3GHz

>Realtek Audio, just incase the crash is actually related to the Soundboard for whatever reason. I've had that issue pop up over the course of my gaming career.

>Post Processing is not enabled, but SFX is.

----------------------------------------------

Config.dat settings:

isFullscreen=true

width=1360

height=658

musicEnabled=true

sfxEnabled=true

palette=0

postProcessing=false

----------------------------------------------


Edit: About 8 Minutes after I posted this it crashed. Felt like 15 though. About 83.6MB used at the time of crashing when I got the error.


Edit 2: Same amount of time. 92.4MB was highest I saw it get. Can't seem to get city population over 40 without it crashing.

Triple Post: So to update you, it worked with my desktop which is a pretty beefed up computer with windows 7.

On my laptop I ran it in compatibility mode, tried to run as admin, gave it special permissions, the usual. No avail. :( About 7 minutes at the dot.

Not quite sure why, but it still keeps crashing on my laptop. I'm starting to wonder if it's issues with the onboard graphics card and not a dedicated GPU.

Developer (1 edit)

Does it also crash when you open a city and just let the game run and not play? If so, then yes, it must be some sort of graphics/driver issue since no game logic is run unless you click stuff.

I found an old piece of a junk laptop with integrated graphics where it runs fine. But it doesn't have Windows 10. I'll have to see if I can upgrade somehow.

Yeah, I can just open it and let it sit. Around 7 minutes exactly is when it crashes without fail every time. I still play it on it, but it's still being dumb, lol. Might be a windows 10 issue? Might not be, idk. I'll see if I can update the gpu anymore than what it is already at, but I believe it's at the best driver currently public.