Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Evolution RTS

Evolution RTS is a free an Open Source RTS game designed using the Spring Engine. · By Scary le Poo

Why did you get rid of Linux support? [Edit: It's back now 12/31/2020]

A topic by Coding Wizard created Apr 16, 2020 Views: 986 Replies: 9
Viewing posts 1 to 6

Why did you get rid of Linux support, it worked fine and me and my brother played it every day through steam but then you removed the support for Linux, so why?


There are a couple of reasons, although you can actually still play it via linux and I'd be happy to walk you through it if you like.

Ok so basically, there is a pretty big issue with infrastructure. Support for our original lobby ended (as in the lobby protocol changed and our lobby was deprecated), so we had to switch to a much nicer, much newer lobby. The problem is that this lobby requires the use of a launcher which does not support the game staying in it's install directory.

On windows there is a large issue with programs shoving EVERYTHING into appdata. This is not only stupid, it's extremely problematic, because appdata is hidden from users. Of course if you are aware of it you can access it, but the vast majority of windows users will be oblivious to it. Meaning that appdata becomes very bloated over time with leftover shit from programs that have been uninstalled long past.

I raised absolute hell over this and absolutely refused to allow evo to get sucked into this shitty practice. That insistence on doing things the right way unfortunately didn't carry over to linux. I don't develop the launcher, so I really have little say in it other than to bitch at the developer who does work on it. Welcome to Open Source.

Steam explicitly forbids placing files outside of the program install folder (and doing so is some serious asshole design). A portable launcher for linux has not been developed, so frankly, I can't include it.

That said, I can't help you get it running on linux. However, this comes with the explicit understanding that it will intermingle with anything else you have installed that uses the spring engine.  This likely will cause 0 issues, but the disclaimer stands.

You can get it here:

Just scroll down until you see the download links section and click the linux one. You won't have the music with this option. However, if you do want the music, just tell me here and I'll make a quick guide on how to add it (it's pretty easy).

Well that makes sense. Also on Linux there are no files hidden from users and you can do literally whatever you want to your files and pretty much anything else on your PC. But yah I can see how that bloat can be annoying.


That's not true. You're forgetting about .directories. In fact, the engine will, by default, install to ~/.spring. I get what you're saying though. In particular appdata is intended to hold data for apps, like settings files, etc. Not entire freaking programs. Google chrome started this crap and when developers saw google doing it, some of them followed suit and now appdata is a giant mess.

This also serves a very practical purpose as well. Many people will have a small super fast ssd or nvme drive just for the OS and a separate drive for programs. Appdata lives in the user's home folder (the equivalent of something like ~/.appdata). This means that programs installing themselves to appdata is a major issue due to the fact that the OS drive is intended to be used strictly for the OS, but programs are circumventing that and installing themselves to appdata.

It's a stupid, shitty practice, and developers who do this should be raked over the coals for doing so.


Took a long time and a good bit of work, but linux 64 is now available again. Let me know if you run into issues.



Unfortunately it isn't working correctly. SMH.

I just can't win. I'm trying to do something about it.

Yah, just found that out it says.

Starting Spring from: /home/REDACTED/Documents/Evolution RTS/engine/105.0/spring

Launching Spring with command: /home/atticus/Documents/Evolution RTS/engine/105.0/spring --write-dir

/home/REDACTED/Documents/Evolution RTS --isolation --menu rapid://evo-chobby:test

Loading dev extensions: false

/home/REDACTED/Documents/Evolution RTS/engine/105.0/spring: /lib/x86_64-linux-gnu/ version `GLIBC_2.29' not found (required by /home/REDACTED/Documents/Evolution RTS/engine/105.0/spring)

Spring failed with code: 

Glibc_2.29 is missing which is non compatible with Ubuntu 18 so sadly I can not play it. Though it should work on Ubuntu 19, 16, and 20. Although I have not tested it.

But the launcher works and I even did an update. I also tested the Stable, Dev, and Portable versions, all had the same error.


Umm so I never replied to this... In the past year I've been able to properly support linux. The developer of skylobby is wonderful and super responsive, so any issues we have come across have been resolved quickly.

: )