🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Wont open on my mac

A topic by dovaka created 136 days ago Views: 221 Replies: 7
Viewing posts 1 to 6

I have put this on my macbook pro and no matter what I do i get this "The application "FPVFreerider" can't be opened." i have done all the things it said to try and none of them work. what else can i look at?

Developer

How do you mean that the things it said to try didn't work?

Do you mean that you managed to do them, but it did not make a difference, or, do you mean that you were unable to do them?

Here are some general Mac tips that are also in the manual:

1. If you unzip the file on a Windows machine and transfer the file to your mac with a USB stick it should work.

2. Better solution for anybody else who has this problem. OS X is picky about which programs can be run (the first time) by double-clicking. To run a program that says "this can't be opened", right-click the icon and choose "Open". You'll be given an option to open the program, and from then on it won't bug you.

3. For Mac's having trouble installing FPV Freerider try going to the Mac's System Preferences>Security and Privacy> General Tab and check the box "Anywhere" to see if this allows your Mac to install FPV Freerider.

4. So i have banging my head with frustration about not being able to even open the program in OSX 10.10. I have finally solved the problem for anybody who is still having the same issue i was, you have to open up terminal and type chmode +x (fpvfreerider.app) and that should do it. Hope this helps anybody.

those things you listed are the things i tried and none of them fixed the issue. I have OSX 10.12.4

Developer

You could try to download the zip again in case it's some rare situation that it got messed up somehow. Otherwise, it sound like a permissions thing to me. When you performed suggestion #4, did you get some kind of confirmation that the command was executed? I don't own a Mac myself though, so I hope some Mac user will be able to chime in.

i did try to redownload and unzip on a windows computer again. your permissions command was actually written slightly wrong so i had ot modify it slightly but it returned me to a prompt with no error

so now i have reinstall OSX clean and even bought the recharged version of free rider and im still getting the same results

also your chmod script in the download section isnt written correctly.

sudo chmod +x ~/Applications/FPVFreerider_Recharged.app

When you put the tilde in there it assumes to look at the user account your currently on but when you put an app in by default it puts it in the main application folder so it should be

sudo chmod +x /Applications/FPVFreerider_Recharged.app

as Applications is a root directory

I tried editing the script as well as putting the app into the place the script wants it and i still cant get either to work.

after screwing with it for hours i finally determined that it was whatever zip format you use that was causing the issue. On my mac i use the program keka to unzip things which wouldnt let it run so i went to my windows computer that uses winrar and that also didnt work and eventually i tried the built in unzip utility in mac and that worked fine and opened right up afterwards.

Developer

Glad to hear that you finally got it working! Thank you for sharing the information, hopefully that will be of help if someone else runs into the same issue.