Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Bugs or issues

A topic by Asobi.tech created Mar 02, 2020 Views: 216 Replies: 15
Viewing posts 1 to 4
Developer

Found any problems with the current build of MaoMao Castle: A Magical Cat-Dragon Fantasy Adventure?
Please state clearly what the problem is,
If you are able to recreate it,
What appears to cause it,
What version of the game are you running,
What Operating System you have,
Any other relevant detials.

Thank you.

Hi Quang!  Hope all is well with you.  So I've got my leap controller and its working ok with the V4 software under Win 10.  I cant seem to get it working with MaoMao castle though.... Is that a bug, or is it something you've not included in this build?  Id love a copy of the version that uses it please if the latter! 

thanks

Simon

Developer

Hey Simon, thanks for getting in touch.
You are correct in that I have not included the LEAPmotion control in this version of the release.
But sit tight, I will be compiling a LEAPmotion version real soon. You're not the only one that has been asking for it.
Watch this space.

Great thanks! Looking forward to it! 

Developer

Version 0.5.1 released to include LEAPmotion controls.
Press 'L' on the title screen.

brilliant - will go get it! thanks

Hi Quang.  So I have Leap_Motion_Developer_Kit_4.0.0+52173 - the latest LEAP drivers and software installed along with the SDK and its all fine on the diagnostic checking (see grab below).  However when I run MaoMao, it doesnt recognise it then pressing L.

Im running Win 10. 

Is it that you are using the old 2.5.1 Dev kit?

Developer (1 edit)

I am also using the v 4.0.0+52173 drivers for my LEAPmotion.


Just want to make sure when you are pressing L on the title screen to toggle the LEAPmotion on you are getting the LEAPmotion Height: setting message at the bottom of the screen?`

hi - so I previously hadn’t got any leap drivers installed. I have installed 3.1.7.2 now (the installer removed the 4.0.0.0 automatically which perhaps was a bit weird) and it now works with the game!

I may well install 4.0.0.0 on top and see if it still works since you are using them... 

oh by the way yes I was getting the height message even with v4.0.0.0 drivers 

Developer

That's great to hear,  you're getting some MaoMao Castle LEAPmotion action in your life :D

Hi Quang, just tried loading the game now (yeah!), but this is the error message I get when I try to launch it:


___________________________________________
############################################################################################
ERROR in
action number 1
of Create Event
for object g:

Error defining an external function.
at gml_Script_leap_dll_init
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_leap_dll_init (line -1)
gml_Script_leap_init
gml_Object_g_Create_0
called from - gml_Room_Rm_AsobiLogo_Create (line -1) - <unknown source line>

I'm using Windows 10, if that's any help? After that the only option I'm given is to "abort".

Developer

Thank you for getting in touch @RyanTwoFeet,
Looks like it's having  a problem initialising the LEAPmotion extension code.
If you do not have a LEAPmotion, please download version 0.5.0 for Windows, I have re-activated it.
I am going to have to do a lot more testing to get stable LEAPmotion compatibility working.

Brilliant, thanks very much - it's working fine now. Got to wave 13 before running out of lives :-)

Play Expo in my flat!

Developer

That's great to hear that it's working fine now.
Can I just check you don't mean that version 0.5.1 is working for you?
Or did you download version 0.5.0 for it to work. 

Thanks.

Yeah, it was 0.5.1 that wasn't working - 0.5.0 is fine.