Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Unable to load images or projects on one specific computer

A topic by Ilonen created 36 days ago Views: 34 Replies: 5
Viewing posts 1 to 5
(+1)

As the title says, I can't load an image into the program. The laptop I'm using comes up with the message "...failed to load image".  This seems to happen on all version, even the trial. I am able to save a project, but trying to open it will shut down the program. No log file is generated, but the folders in AppData are. I've tried the program on two other desktop PC's and they had absolutely no trouble. They were able to load any image I selected.

Any idea why this happens?

This is a fairly new computer (got it 2017?). In fact, the two others I tested are older/have older parts. It's a Dell Precision 3520. In short: Quadro M620, i7-7820HQ 2.90GHZ, 16GB of ram, Win 10.

Could there be some antivirus or firewall kind of blocking file access from this program? I think I installed Windows on this as a business type or something of the sort? It does have a ridicilous amount of pointless software on it. 

So far I've done all the software updates I could think of, moved to folder around, tried launching as administrator and played around with firewalls etc.

Developer

Hi there. That's quite a tricky sounding situation. My first suggestion would be to try running as admin but you have already done that. I think your intuition may be correct concerning some kind of antivirus blocking it from accessing the hard-drive. Conversely, it could actually be an infection on that machine that is causing you trouble - something that is trying to prevent anti-virus from detecting itself by dictating what programs running on the machine are able to read/write. The folder that PixelCNC outputs log files to (or is supposed to) is one that it should have access to even if you are not running as administrator - it's a special area that Windows permits as being a safe place for programs to write to the hard-disk without the threat of them corrupting the system or anything like that. Since it's not able to read or write anything from disk I would suspect that it's something that could be running in the background preventing PixelCNC from accessing anything.

I would suggest checking what programs you have running - likely some things are sitting right in your system tray on the right side of your task bar - you could try investigating those. It very well could be some kind of anti-virus that's purposefully preventing PixelCNC from interacting with the disk drive because it's currently an unsigned executable - which is to say that it has no identifying information proving where or who it originated from. This is because many viruses are also unsigned - authors must use government issued identifying documents to prove their identity to a central authority that distributes certificates to publishers and developers and someone writing malware does not want to jump through those hoops only to tie their real identity to their malware. I simply have not jumped through the necessary hoops yet to sign PixelCNC but will do so once it reaches beta in just a few more months. This may be causing overzealous anti-virus to completely block it entirely. Ironically, malware authors have since begun stealing code-signing certificates to sneak their malware right under the nose of anti-virus, so it's become somewhat futile - but I suppose it does prevent low-effort malware from wreaking havoc on a system.

Try temporarily disabling any AV you have running - or going into its settings and seeing if you can manually add PixelCNC to some kind of exclusion white list. I would think there is something running on there that isn't running on your other two systems, and maybe that would be a good clue as to where to start looking.

Let me know if you make any headway or find any clues. I'll check in with some of my software development circles and see what I can find out.

 Charlie

Developer

I did find this, if you look at a program's properties some may be "blocked" because they "came from another computer", with an option to unblock the program:


Let me know if you see anything like this with the PixelCNC exe.

 Charlie

(1 edit) (+1)

Huh, so loading a picture directly from a USB drive works and PixelCNC doesn't crash when opening a project from there either.  I messed with security and access stuff some more but didn't find any solutions there. I also didn't have that unblock option in PixelCNC.

I'll see if any issues arise from having the files on a USB stick. I'll be getting a proper new PC in the near future, so not a huge issue if this solution doesn't work properly.

Thank you for the quick response!

Developer

Hrm, it sounds like you have some security set on your hard-drive, or at least on the folders on your drive. I don't know exactly what the default settings should be but here's what mine look like for my Windows 10 drive (my C drive is my Windows 7 drive):


I suspect there's something going on there, if it's not some kind of anti-virus/Windows Defender thing. I don't know which "user" you would need to check the permissions of, whether "Authenticated Users" or just "Users". Maybe check the security permissions on your USB drive and compare with your HDD? I have yet to find anything that seems relevant on Google, or heard anything back from anyone else. Definitely a strange situation!

 Charlie

Developer

I did some more research and someone suggested that perhaps you have Windows Defender's "controlled folder access" enabled. Here is the link they mentioned: https://docs.microsoft.com/en-us/windows/security/threat-protection/microsoft-defender-atp/enable-controlled-folders

Apparently there's a means of whitelisting programs, or you could otherwise just entirely disable the feature. I don't know for sure what would be good practice for yourself because my computer habits are surely different than yours and anyone else's, so it's your choice if you wish to disable such a feature. That being said, you seem relatively savvy and I would think that you would be perfectly fine with the feature disabled, because I am sure it would be preventing many other 3rd party programs from functioning properly that you might wish to download and use. PixelCNC isn't doing anything out of the ordinary when it comes to reading/writing files, it's pretty much bog-standard routine stuff for programs going all the way back to the Windows 95 era.

It'd be a great help if you could confirm whether or not this is the issue. Thanks!

Charlie