Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

no amiga os 3.x version?

A topic by uigiflip created 29 days ago Views: 73 Replies: 1
Viewing posts 1 to 2

only os 4.1 you need mortgage for a computer capable of amiga os 4.1 lol

Developer (5 edits)

Hi uigiflip,

you're absolutely right :D

To be honest, I would have loved to make Blastaway only for AGA Amigas, but I had to go a different route. I'm sorry to say that Blastaway won't land on classic Amigas for several reasons.

In general, other platforms won't be considered because:
 * I can't take the burden of adapting the game and then of offering (future) support (two platforms are already demanding, and with BOH I've learned that increasing the number of supported systems beyond two is insane);
 * porting is boring;
 * help offers aren't of any help (terrible pun intended) because also collaborating, for several reasons, takes time and energies;
 * I don't own all the machines I'm being / I will be asked to port the game to, and for money and logistical reasons I can't get more;
 * I have many other projects (for classic Amiga and Commodore 64) waiting to be resumed, and time and energies are limited.

In particular, a classic Amiga version won't happen because:
 * it couldn't be identical;
 * it would require a huge development effort, as no direct port is possible: the code would have to be written from scratch and the data would have to be adapted;
 * it would require an additional effort for testing, given the variety of hardware configurations;
 * it would require again a big effort in case of updates (if any).