Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Seamless Loop not working as expected

A topic by Ofenkatze created 86 days ago Views: 73 Replies: 4
Viewing posts 1 to 5

Hi there,

i don't know if this is maybe a bug or if I'm doing something wrong, but the Seamless Loop Feature of Blast FX does not work for me. Here's what I did:
- created a repeating emitter
- turned on seamless loop
- set Preprocess to match particle lifetime (no Lifetime Rand, though I don't know if that's even necessary)
However, once rendered, I start with an empty frame and the particles are building vom zero. It seems that no preprocessing is applied, hence no seamless looping possible.

Am I doing it wrong? Any hints greatly appreciated.

Best regards
Ofenkatze

Developer

Sorry to hear your having issues, the seamless looping is a little tricky sometimes. 

Could you possibly upload your project file somewhere so I can take a look at it? That'll probably be the fastest way for me to diagnose the problem 

(3 edits)

Hey Ben,

thx for the quick reply. I have uploaded an example project with the problem occuring to
https://ufile.io/2ifdscsh

I had some partial success with setting Delay Capture to my particle's lifespan (i.e. cutting the buildup framewise), but it seems not to be working in all cases...

Edit: I'm exporting at 16 fps, maybe that's the issue?
Edit2: I got the workaround to work reliably when rendering at least 2 seconds worth of frames. It DOES work this way, but it also means a lot of manual labour since I have to export single images and delete every second frame and then build the spritesheet in Photoshop.

Developer

Thanks for the project file, it took me a while to figure out what was going wrong (been a while since I've worked with my own software!) but here's what you need to do:

Output Frame Count = Output Frames Per Second x Emitter Lifetime

So in your case, your emitter lifetime is 2, your desired frame rate is 16, so your output frame count should be 32

That should give you a seamless loop. I'll try and change it so that those settings are updated automatically when you enable seamless looping, as a lot of people keep running into this problem (understandably).

The delay capture thing is a bit of an ugly work around for a bug I haven't been able to solve yet, but I think it's more to do with the engine I'm using. Hopefully I'll be able to avoid empty frames without relying on that eventually.

Hope this helps!

(1 edit)

ah yes, that did the trick, and explaines why the workaround did work with two seconds in the example XD Also, fairly logical, coming to think about it....
Thanks a bunch!