Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

DragonRuby Game Toolkit

An intuitive 2D game engine. Fast, xplat, tiny, hot loaded. · By DragonRuby

libudev.so.0: cannot open shared object file: No such file or directory

A topic by kettek created 63 days ago Views: 96 Replies: 4
Viewing posts 1 to 4

Running on Arch Linux and got the above error. Tried to simply link it to my system libudev with `ln -s /usr/lib/libudev.so /usr/lib/libudev.so.1.6.14` but that only resulted in `Couldn't create game context: Failed loading udev_device_get_action: dragonruby: undefined symbol: _udev_device_get_action`.

What version of libudev is the Linux binary linked against?

Hmm, this might be a separate issue, as it is working if I run dragonruby from its unarchived directory. I had copied it to my local binary PATH, but that seems to be problematic.

Further verification shows that it is fine if I simply symlink to the dragonruby programs in their unarchived directory rather than copying them elsewhere.

This thread, it seems, should be ignored.

Developer(+1)

Just seeing this. We need a better error message if "all the files" have not been copied of (dragonruby needs the binary, the logo, and the font). You need to copy over all 3 files and that should work.

Ah, okay, I was unaware of that, although I should've realized it would at least need those assets to even run -- thanks for the info.