Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

What the box?

You're a box, and you're trying to kill other boxes, in a place filled with boxes. · By Bitten Toast Games

Boxes don't like gamepads

A topic by ifo created Sep 01, 2016 Views: 606 Replies: 5
Viewing posts 1 to 4

No, this is not a topic whether keyboard / mouse or gamepad controls are better :-)

I'm having a different problem: On Linux (Slackware64 14.2 in my case) and with two different console gamepad converters (EMS Trio Linker Plus II and Bliss Box) the game is crashing on start if a controller is connected. Judging from the log (see below) the input library seems to cause the crash. Apart from that the game is running perfectly and is perfect fun - thanks a lot!


 at (wrapper managed-to-native) IxboduSEWeEfUOCcbJLzYAjUvjN.cYDfacSWXeRkenHjXeMXFWdJESx (intptr,string,string) <0x000b8>
 at (wrapper managed-to-native) IxboduSEWeEfUOCcbJLzYAjUvjN.cYDfacSWXeRkenHjXeMXFWdJESx (intptr,string,string) <0x000b8>
 at IxboduSEWeEfUOCcbJLzYAjUvjN.JFYETsstakHPRjykrGTMhusUgmX (intptr,string,string) <0x00028>
 at racuqrGfcNAVVxmXGLXtGBVGPsd.JFYETsstakHPRjykrGTMhusUgmX (intptr,string,string) <0x0003b>
 at EZPQDGiWHsubHsxsOkPDJKHoLPu.LVFadESqqJtmKWCUVXwwSpInJFo (intptr) <0x00345>
 at EZPQDGiWHsubHsxsOkPDJKHoLPu..ctor () <0x00133>
 at Rewired.Linux.LinuxInputSource..ctor (Rewired.Config.UpdateLoopSetting,bool,bool,bool,bool) <0x00041>

 at Rewired.Linux.LinuxInputManager..ctor 
 at Rewired.InputManagers.Initializer.Initialize (Rewired.Data.ConfigVars) <0x000e2>

 at SGOGEfdrBuQcIIQrVpGGMBAQHTHq.pCvjmjNEMejgvjMRWcanISBJqiea 
 at Rewired.InputManager_Base.InitializePlatform (Rewired.Data.ConfigVars) <0x00099>
 at Rewired.ReInput.YRWVGJLLxndyxDUUopzNtFSAIu (System.Func`2<Rewired.Data.ConfigVars, object>) <0x003b9>

 at Rewired.ReInput.pCvjmjNEMejgvjMRWcanISBJqiea 
 at Rewired.InputManager_Base.Initialize () <0x00340>
 at Rewired.InputManager_Base.Awake () <0x00014>
 at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0x0005e>

Native stacktrace:

 /usr/local/games/WhatTheBox_Data/Mono/x86_64/ [0x7f7957404a46]
 /usr/local/games/WhatTheBox_Data/Mono/x86_64/ [0x7f79573a78e4]
 /lib64/ [0x7f795a6413b0]
 /lib64/ [0x7f7958e6fff6]
 /lib64/ [0x7f78cc7afb14]
 /lib64/ [0x7f78cc7afb90]
 /usr/lib64/ [0x7f7955fe7aa4]

Debug info from gdb:

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/".
0x00007f795a64053d in read () from /lib64/
 Id Target Id Frame 
* 1 Thread 0x7f795ac19740 (LWP 24181) "WhatTheBox.x86_" 0x00007f795a64053d in read () from /lib64/

 2 Thread 0x7f7956ce7700 (LWP 24182) "WhatTheBox.x86_" 
0x00007f795a63d718 in pthread_cond_timedwait@@GLIBC_2.3.2 () from 

[... snip idle threads due to message length constraints ...]

 33 Thread 0x7f7940244700 (LWP 24215) "WhatTheBox.x86_" 0x00007f7958ee19f7 in ioctl () from /lib64/
 34 Thread 0x7f7940238700 (LWP 24216) "WhatTheBox.x86_" 0x00007f7958eb0c4d in nanosleep () from /lib64/

 35 Thread 0x7f7940023700 (LWP 24217) "WhatTheBox.x86_" 
0x00007f795a63f847 in do_futex_wait.constprop () from 
 36 Thread 0x7f78cddd1700 (LWP 24218) 
"WhatTheBox.x86_" 0x00007f795a63f847 in do_futex_wait.constprop () from 
 37 Thread 0x7f78cd5d0700 (LWP 24219) "WhatTheBox.x86_" 0x00007f7958ee030d in poll () from /lib64/
 38 Thread 0x7f7957a81700 (LWP 24220) "WhatTheBox.x86_" 0x00007f7958eb0c4d in nanosleep () from /lib64/

Thread 38 (Thread 0x7f7957a81700 (LWP 24220)):
#0 0x00007f7958eb0c4d in nanosleep () at /lib64/
#1 0x00007f7958ee2844 in usleep () at /lib64/
#2 0x000000000147edff in ()
#3 0x00000000014755fb in FMOD::Thread::callback(void*) ()
#4 0x00007f795a637684 in start_thread () at /lib64/
#5 0x00007f7958eebefd in clone () at /lib64/

[... snip idle threads due to message length constraints ...]

Thread 3 (Thread 0x7f7956c56700 (LWP 24183)):
#0 0x00007f795a63f847 in do_futex_wait.constprop () at /lib64/
#1 0x00007f795a63f8f4 in __new_sem_wait_slow.constprop.0 () at /lib64/
#2 0x00007f795a63f99a in sem_wait@@GLIBC_2.2.5 () at /lib64/
#3 0x00007f79574fedcf in mono_sem_wait () at /usr/local/games/WhatTheBox_Data/Mono/x86_64/
#4 0x00007f79574698b5 in () at /usr/local/games/WhatTheBox_Data/Mono/x86_64/
#5 0x00007f79574d117e in () at /usr/local/games/WhatTheBox_Data/Mono/x86_64/
#6 0x00007f79574f6ce7 in () at /usr/local/games/WhatTheBox_Data/Mono/x86_64/
#7 0x00007f7957517836 in () at /usr/local/games/WhatTheBox_Data/Mono/x86_64/
#8 0x00007f795a637684 in start_thread () at /lib64/
#9 0x00007f7958eebefd in clone () at /lib64/

Thread 2 (Thread 0x7f7956ce7700 (LWP 24182)):
#0 0x00007f795a63d718 in pthread_cond_timedwait@@GLIBC_2.3.2 () at /lib64/
#1 0x00007f79574e38c2 in () at /usr/local/games/WhatTheBox_Data/Mono/x86_64/
#2 0x00007f795a637684 in start_thread () at /lib64/
#3 0x00007f7958eebefd in clone () at /lib64/

Thread 1 (Thread 0x7f795ac19740 (LWP 24181)):
#0 0x00007f795a64053d in read () at /lib64/
#1 0x00007f7957404b91 in () at /usr/local/games/WhatTheBox_Data/Mono/x86_64/
#2 0x00007f79573a78e4 in () at /usr/local/games/WhatTheBox_Data/Mono/x86_64/
#3 0x00007f795a6413b0 in <signal handler called> () at /lib64/
#4 0x00007f7958e6fff6 in strlen () at /lib64/
#5 0x00007f78cc7afb14 in () at /lib64/
#6 0x00007f78cc7afb90 in udev_device_get_parent () at /lib64/
#7 0x00007f7955fe7aa4 in udev_device_get_parent_with_subsystem_devtype () at /usr/lib64/
#8 0x00000000411cb3b8 in ()
#9 0x0000000003390650 in ()
#10 0x0000000003391610 in ()
#11 0x00007ffe858c9628 in ()
#12 0x0000000004d024d0 in ()
#13 0x0000000000000000 in ()

Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.

Preloaded type GtkListStore
Preloaded type GtkWindow
Preloaded type GtkVBox
Preloaded type GtkImage
Preloaded type GtkNotebook
Preloaded type GtkHBox
Preloaded type GtkFrame
Preloaded type GtkAlignment
Preloaded type GtkTreeView
Preloaded type GtkLabel
Preloaded type GtkCheckButton
Preloaded type GtkScrolledWindow
Preloaded type GtkComboBox

Damn :( sorry to hear that, I don't have a linux install so I don't usually get to test the linux build, just hope that it works...

So here's what I did, I updated the controller thingie I use (It's called Rewired, for Unity). So try downloading 1.4.5 and please let me know if the problem was solved.

The second thing I did was cross-posting what you posted here in the Unity Rewired Forums, to see if the creator of Rewired knows anything about this. Here's the link to my post:

Welp, thanks for letting me know of the problem ^^

Thanks a lot for the quick response! Unfortunately the new Rewired version still shows the same behavior.

I did some further debugging though and added the results to the Rewired Unity forum thread. Hopefully the developer will be able to fix the problem...


Hey there! Rewired guy uploaded a new version of rewired that might solve the problem. I just updated the Linux build with it (without changing the version number). Let me know if it fixes it! Thank you so much for helping find and figure out this problem :)


Thanks a lot, that solved it!


Yay! Thanks for helping me find the problem and solve it!! :D High five! \o