🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bugs Sticky

A topic by DomDumont created 1 year ago Views: 207 Replies: 12
Viewing posts 1 to 4
Developer

Don't be shy ;-)

I'm sure you found a lot of bugs.

I will try to fix them ASAP

Thx

I just tried to use this for Mac and it says it's not compatible with OS X El Capitan. If you can get it working for this version of OS X I will definitely help you find some bugs.

Developer

Hi,

Sure. I'll have access to a mac in about 3 weeks and will definitely look after this problem.

It may be related to Qt. Did you try installing Qt libraries ?

Throught the latest Qt installer or via brew .

Thanks a lot for your help

Dom

Developer

Hi,


I've just uploaded a new dmg file for mac. Of course this file works on my mac (because I have the full Qt environment)

Please tell me if it's better on your side.

Thanks

Dom

This works now, thanks! I haven't had a chance to mess with it much so I will keep you posted of any additional problems. But I can run the app.

Hi, I get an error saying This application failed to start because it could not find or load the Qt platform plugin "windows" in "". Reinstalling the application may fix this problem.

However you don't include an install program, just the files in a zip folder. I'm running windows 10. I've already installed the VC_redist. Both the x86 and the 64 versions.

Developer

Hi,


Sorry for that, It's a qt distribution problem. I will try to fix this ASAP.

Dom

Thanks, can yo upleas let me know when you do?

Developer

Hi again,


I add a new file (QtExtraFiles.zip). Please try to download/unzip it in the same directory as CartaGen (you should have cartagen.exe and the 'platform' directory at the same level). I'm not sure but I hope it will help.

Sorry, I didn't see this the first time.

Anyway, I downloaded the qtextrafiles.zip file and extracted all the contents to the CartaGen folder. Where all the other files are. It asked to overwrite some files that where in there already, and I let it. Unfortunately it didn't work. I also tried running as an administrator, it still didn't work.

The error I'm getting now reads "The procedure entry point ?toLower@QString@@EHAA?AV1@XZ could not be located in the dynamic link library D:\Program Files\Cartagen-0.2.7-win64\cartagen\cartagen.exe."

Developer

This is a mess, sorry for that.

So last try, i've just upload a brand new windows package (called cartagen-0.2.7-6-g2b86c44-win64.zip).

I hope this one will work this time.

Dom

PS: If you are a developer, I can also put the source code on Github so you can compile everything by yourself directly on your computer.

Hi Dom,

Good news, the new build works fine. I did have one small issue, when I was trying to change the font of the text it didn't want to change, I tried selecting the text and then changing the listed font, I also tried selecting the font and then typing some new text but it kept going back to the default. I did manage to get it to change once but I'm not sure what I did to get it to work.

I guess I am a developer but I don't think giving me the files would do much good. I don't even know what language you are using. I'm currently learning video game development at university. One of our projects for game design was to develop a board game, I enjoyed it so much I'm trying to turn my project into a fully developed game.

Are you still developing this tool? If all goes well I'm planning to test my game on Table Top Simulator and after that onto The Game Crafter.

Developer

Hi,

It's done in c++/Qt.

I stopped developing it because I had very few downloads and very interest from people (even if it's free).

I would like to test Table Top simulator too, it seems cool.

Good luck with your boardgame and with your Video Game university !


Dom

PS: I'm a Video Game developer too (for 20 years now) . Continue to work hard in university, it's a good job ;-)