Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Carpentry Story 馃尣馃獡

Restore town and save residents by making furniture! 路 By fizzlymike

Some Things I Noticed in 24 Hours of Play

A topic by Ash created Jan 15, 2023 Views: 188 Replies: 3
Viewing posts 1 to 2
(1 edit) (-1)

Hello! I saw this game and tried it out and I have to say, I really like it! I did notice, however, some minor issues while playing.

  • The "small table" that is requested in the game is actually the Round Table blueprint. I was a bit lost thinking I needed a new blueprint named Small Table before I eventually tried the round table and found out it worked.
  • The Cafe owner won't accept the tables unless the tables are the only thing in your inventory furniture wise. I couldn't figure out why she wouldn't take them until I decided to test that theory. She then took the tables and I was able to complete the Cafe.
  • The Baker doesn't seem to stock her shelves no matter how many days have passed since completing the bakery. Not sure if that's on purpose or not. Same for the bar. He just seems to be stuck on waiting for the wine to be made after giving him all the barrel stands.
  • The Barrel and Bucket blueprints show clam shells as part of the ingredients list on the blueprints. This had me looking forever for the shells before I finally tried the iron clamps in the recipes. I thought I had to acquire the clam shells somehow.
  • I had an error that made me restart the game when I tried to buy from the Captain before reaching a certain part of the game. I'm not sure what finally triggered my ability to buy from him but at one point that error just went away and I could finally buy without crashing my game.
  • The Wardrobe seems to be labelled as "Bucket" for some reason when you go to place it down. And when you go to  craft the "Dresser" it comes out as a wood pile and the recipe doesn't work. I'm guessing these were just meant to be the same thing and only the wardrobe recipe is valid now.
  • I've upgraded my house and completed the church, the town square and all the shops but the one with the notice on the door, and I'm not sure how to proceed from there as nothing seems to trigger a new cut scene  or quest. Not sure if this is intended and it's just not finished or if I'm just missing something to trigger the next section of the game.

Other than these things, I've really enjoyed the game so far. The concept of repairing the town to progress was really well done and I've enjoyed the flow.

Wasn't sure if I should have posted this in the thread on RPG Maker forums because it's been kinda dead for a while and I didn't want to chance getting dinged for Necro'ing the thread.

~Ash

Developer (7 edits)

Thank you so much Ash for playing CS and for a bug list to fix. The game should have and ending if you fixed all the buildings with square, the one with note on door is not avaible (it's supposed to be your shop later in game). You just need to play forward a few days to trigger the cutscene, please try to do this and let me know if you have the cutscene. I'm starting to fix the bugs right now!

1. Dresser is not the same thing that Wardrobe, just fixed the error that made "failure" while following Dresser blueprint.
2. Fixed bug with showing clams instead of iron clamps in Barrel and Bucket blueprint.
3. Unified the name for Small/Round table, it's Small tables.
Working on other things before I'll post the updated version.

Ah! Ok, it took a couple more day  skips but it finally triggered the end scene. That's such a wonderful ending!

Developer

I'm happy that you liked it! Will work for fixing the rest of bugs you've mentioned. Thank you very much.