Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Neofeud

Cyberpunk Adventure / Visual Novel · By silverspook

Found there is a version for Mac but cannot launch it...

A topic by yokoxyy created May 15, 2018 Views: 747 Replies: 14
Viewing posts 1 to 4

Hi,

Just bought the game cause found there is a version for Mac. However, I cannot launch it after unzip it.

Don't know what happened. Can u help me :(Really want to check out this game. 

Developer

Hi yokoxyy, thanks very much for buying Neofeud. Sorry that you had trouble running it, though!

Do you have Gatekeeper or any sort of anti-malware that might interfere? I heard one Mac user had to set Gatekeeper to allow apps to start from anywhere (temporarily) or Neofeud wouldn't load.

You may also want to try this:

There is a problem in Wineskin GPU detection code with High Sierra changes.
By default your wrappers may crash or fail to launch.
Currently you can work around this by launching Wineskin.app, going to Set Screen Options, and uncheck the Auto Detect GPU for Direct 3D option, and the wrapper should work normally.

http://wineskin.urgesoftware.com/tiki-view_blog_post.php?postId=87


This thread may also be helpful Mac: https://itch.io/post/342870

Please let me.know if you still have trouble, and thanks again!

-Christian

None of the things you suggest here or in the other thread work for me, since it won't start at all ("Can't find file") so I can't change the "Auto Detect GPU for Direct 3D" option, though this has worked for me for other games using Wineskin.

Developer

Sorry that you had trouble running the game! Does it say which file is unable to be found?

No, it doesn't. I deleted everything and redownloaded the zip file, now I get the following:

This is my normal Downloads directory, so the error message is a bit baffling. If I cd into the app bundle and directly start Wineskin.app it starts and I can disable the "Auto Detect GPU for Direct 3D", but "Test Run" gives me the same error as above again. I tried updating the wrapper, but that just leads to a hanging Wineskin process.

Then I figured that unlike normal macOS applications Wineskin may not like it when you start it from random folders (not a big Wine user, so that was just an idea). So I moved it from Downloads to Applications and lo and behold the error goes away, but nothing at all happens when double clicking the app. Opening it from the terminal with open -a Neofeud leads to the following error:

LSOpenURLsWithRole() failed for the application /Applications/Neofeud.app with error -10810.


I then tried to run a dtrace on it (which current macOS makes unnecessarily hard btw) but the only somewhat interesting things I noticed were 

dtrace: error on enabled probe ID 2172 (ID 170: syscall::write:return): invalid kernel access in action #13 at DIF offset 68

though it's hard to say if that's really related to Neufeud since the dtrace workaround is essentially tracing the PID of another terminal. Anyway, I think this is the point where I give up for now ;-)

Developer

Wow, sorry it has been such a rough time with this!

Hm...  If you haven't already, perhaps re-try the other suggestions (temporarily disabling anti-virus software, etc) now that you've moved Neofeud to the Applications folder?

There are some errors that Wine causes that are system specific, if you give me your specs I might be able to help with that.

No worries, as a software developer myself I may have gone a bit overboard on the debugging, but I did actually enjoy it.

System: newest Macbook Air (end of 2018), 16GB of RAM, newest macOS (10.14.6 ), and I don't run antivirus software so that's not the issue. It'd probably have an easier time just installing the Linux version on another device, but I'm somewhat curious now. BUT: I highly recommend not advertising Wine as Mac version in the future, it sets wrong expectations.

@silverspook Any news on this? I still haven't been able to play the game and I purchased it quite a while ago :-(

any resolution found?  

Nope, I never got it to work on a Mac.

(2 edits)

It works for me on my Mac running macOS 10.13 High Sierra. This sounds like a compatibility issue with macOS 10.14 Mojave.

You need to use an updated version of Wineskin that is compatible with Mojave. I found a thread about it here: https://portingteam.com/topic/11072-mojave-and-wine-versions/.  The updated version of Wineskin is available here: https://portingteam.com/topic/11037-unofficial-wineskin-project/. It is technically unofficial since the official Wineskin hasn’t been updated in several years apparently, it looks like official Wineskin last had a release of 2.6.2 in 2015 while the unofficial is up to version 2.9.0.4 from August 2019.

That should hopefully fix Mojave compatibility. Luckily my Mac is still on High Sierra (it is actually incompatible with Mojave due to old hardware) so I am not affected by this problem and the game works for me.

This unofficial version does have a little downside though. It raises the minimum macOS version requirement from 10.6 Snow Leopard to 10.8 Mountain Lion,  and it is recommended to have macOS 10.9 Mavericks or later with this new unofficial version. But it works better on 10.14 Mojave and 10.13 High Sierra and is more likely to work on 10.15 Catalina.

So I suggest having 2 different downloads, keeping the current one that works without any issues on 10.6 Snow Leopard thru 10.12 Sierra (better for the older versions of macOS), and also adding one with the updated Wineskin that works without any issues on 10.9 Mavericks thru 10.14 Mojave (better for the newer versions of macOS) and possibly might work on 10.15 Catalina. For macOS 10.15 Catalina the entire app needs to be 64-bit and 32-bit software absolutely will not work.

Does this mean I need to repack my downloaded wineskin app?

Developer

Valentbr - I've just added a new Mac version of Neofeud that should work with your version of macOS. The new Neofeud Mac download should work with macOS 10.8 - 10.15. I believe you have Mojave (10.14).

The old Mac download is still there as it works with macOS 10.6 - 10.13, in case there some Mac users with older versions of the OS.

Special thanks to General Public for helping create the new Wineskin package!

Thanks. did anyone get this to work?  I got corrupted file error several times. 

Hello, I tried with xattr -cr ~/Downloads/Neofeud.app

which worked for https://itch.io/post/1461189


Unfortunately now I get error