🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Help Request - Mouse Lock Issues with Unity build

A topic by Justin.kau created 10 days ago Views: 30 Replies: 1
Viewing posts 1 to 2

I'm having a weird issue where my cursor will not lock in the game window. I've tried just about every combination of "Embed Options" possible, but with no success. I've seen a few old posts with similar issues to this, but they have no resolution other than a browser issue. I think something different is going on in my case as I am able to achieve correct mouse lock in older games that I have uploaded using similar builds, but in my most recent games with the same browser am unable to lock cursor. Here are two examples.

https://justinkau.itch.io/kesey-square-2 - This is a game I just uploaded a few days ago and I cannot achieve mouse lock in the game window.

https://justinkau.itch.io/strawberry-plaza - Whereas this is a game that I uploaded about a year ago and it locks the mouse just fine (both run on my Windows 10 machine in Chrome). 

Both of these games have the standard Unity  First-Person controller and I have not modified the scripts for either.

I have four versions of this "Kesey square" game and they are all functioning the same way. 

Any help would be greatly appreciated!

So, I'm not sure where the issue was happening, but removing my PlayMakerGUI solved the issue. 

This must've just been some random bug because it only occurred in one of four (mostly) identical builds. All the builds had the PlayMakerGUI, but on a hunch after digging through lots of issues with Cursor.lockState I tried removing it from the one problem scene and voila...

I sincerely hope this may help if anyone is having similar issues. I spent many frustrating hours on this one.