Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Fell Seal: Arbiter's Mark - Demo

Turn-based tactical RPG focused on storytelling and character customization. · By 6 Eyes Studio


A topic by mankyking1 created Feb 18, 2018 Views: 729 Replies: 5
Viewing posts 1 to 6

i have an error, (unfortunately) when i try to run the game (mac version)after the 9 eyes logo (or what ever it it) the game goes to a black screen and doesn't change. can i get some help?


Hello :)

I've heard from some mac users that the game secretly "loses focus" sometimes after starting it, so it looks stuck on a black screen, but it's actually just not focused and 'paused in the background'. Try forcefully giving it focus again.

If that doesn't do it... I admit I'm not sure. The mac demo build is quite a bit outdated by now compared to our main game version as we've redone a lot of systems to ensure the Mac build runs as smoothly as possible. We'll eventually put a new demo build up, but we're focusing on our Beta Backers build currently.

what do you mean "Try forcefully giving it focus again." i tried pressing every button but that did nothing...

annnnnnnnnnnnnnnnnnnnnnnnnd it works now that i checked it again... *facepalm*


focus: basically, click on it.

We have a new build and I believe this issue should be resolved in it. We're planning on putting it up soon. It contains about 6 months of various fixes from our Beta Build and should be looking a lot better :)

Unfortunately I get stuck early on in the demo - I get a black screen with either the guild or shop options in town one. Is there a fix for this? I'm running windows 10.


Yeah, we found an issue in the Demo build where some assets were missing, including the Shop/Guild maps.

Very sorry about that!

The latest build should have everything working correctly again, as well as the latest balance updates, sfx, vfx, etc.

Thanks for your patience with this!