🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

[Map] [SOLVED] Map Over other actors

A topic by Lacroiix Lancaster created 1 year ago Views: 300 Replies: 8
Viewing posts 1 to 5
(Edited 2 times)

Hi, me again! x)

Guys, I create a map, but when I import to scene, he cover the other actors o,o. Why this occurs? How to solve?

[ Screenshot ]

(+1)

Hmmm, maybe you need to change the z axis value of your actor. It could be that the map is being drawn in front of them.

Hope this helps.

(Edited 1 time)

I guess same thing. How I change the value of z axis? (is in "position" propriety?)

(+1)

Yes, it should be the 3rd value in the position property.

A good idea might be to switch to 3D mode when working with the z axis and then switch back when you are done. It might make it easier to see why something might be displayed on top of something else.

Not work ):

Darn, I'm not sure what it is then.

Ok, thanks ;)

(+2)

A few things you might try:

  • Make sure the Z position of the map is not the same as the others. Try setting it to -5.
  • Make sure the Z position of the camera is not the same as the others. Try setting it to 5, or 10.
    The three boxes are X, Y, and Z. The one on the right is the one we want to change. This can be found in the scene editor.
  • Make sure the scene was loaded.
    This has happened to me before, so you might want to check ;)
  • If the background is being covered by other tiles even though they are transparent, make sure to put them in another layer.
    This can be done in the tilemap editor.
  • If the actors are covering the background, make sure the sprites are transparent.
    You can check this in the sprite asset.

Other than that, I'm not sure what it might be without some more info. I hope this helps you find out what's going on. :o

(+1)

After the explanation from scriptMapBoy I did understand what uheartbeast want says. The answer was in Z axis all time. But my map had 5 in Z axis, so my PlayerActor had 2 or 3, so it never appear x).

Thank you all. <3