Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

The Norwood Suite

Journey to a hillside hotel brimming with odd characters, old secrets and head-nodding music. · By Cosmo D

Installation blocked by Windows 10 Smartscreen

A topic by wmterhaar created Dec 19, 2017 Views: 1,500 Replies: 13
Viewing posts 1 to 7

The installation of The Norwood Suite is blocked by Windows 10 Smartscreen. This is no problem if you download it from the Itch.io site, because you can click it away (although it might make some people suspicious that the game is infected with a virus), but if you try to install it from the Itch.io app it doesn't work, because the Windows 10 Smartscreen prompt is supressed and the Itch.io itself doesn't give an error.

Developer(+1)

I'll get in touch with Itch about this.

I'm on Window 10 as well, and I had the same problem with installation.

Developer (1 edit)

Try running the Itch.io app as an Administrator - any change?

when i try to open the file it just get removed idk y can u help me

Developer

Email your issue, with a detailed explanation of what is happening, to support-at-cosmod.net and we will try to sort it out.

ok so when my download was complete i double click on the download and it just say removed. i tried using YouTube  but i didnt find the video that i was looking for it was just failed download or virus detected. so please help me.

Developer

One thing you can try to do is install the game using the Itch.IO client.

https://itch.io/app

This may allow you to bypass the Smartscreen protection. If this doesn’t work, lmk and I can also DM a Steam key to your account.

When i download it the first time it worked but the screen wasnt loading so uninstalling and reinstall it and when i open the app i immediately get kicked off the app so i open it again and it does the same thing so i uninstall the app and i reinstall the app and i immediately get kicked off like at this point im about to break my laptop.

and also can i dm you on discord so i can send the video about my problem. if thats fine by you. 

Developer

Yes, that's fine.

user smit_play123#7788

Did you manage to fix this? I have the same issue with my own game..

Developer

Have you tried downloading using the Itch.io client?  Or running as an administrator?