Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

I can't download the itch.io app

A topic by UnknownUser752 created Oct 31, 2021 Views: 2,336 Replies: 13
Viewing posts 1 to 13
(+3)

Hello, I wanna install the itch.io desktop app and every time I try to go and click the download button on https://itch.io/app it just says this 

itch.io API error (403): /games/266568/uploads: invalid key

Can anybody help me with this?

(+2)

I have the same issue, getting it resolved would be nice.

(+2)

Same issue here. Is there an outage of some kind?

(+2)

I have the same issue

(+2)

Having the same problem here. I don't see any replies with a fix. 

it's fixed, for me at least. I didn't do a thing. I just saw in another post that the problem was solved.

(+2)

yeah couldn't update the app for some reason, so i uninstalled and now that i try to install again i get the same issue

(+3)

Seems like devs broke something. They'll probably fix it soon.

(+4)

Huh same error here, I think it was forcibly removed temporarily as the link cant find the download directory. 

Maybe they're tweaking something with the app?

But dang that's a long fix as according to the thread it's been more than 15 hours already and I tried to download it earlier too but figured they must be updating it or something but it's still not up... It makes me sad that I don't know what's goin on as there doesn't seem to be any updates on the issue.

(+1)

I try to download and install from Epic game store. It got an error too. 

(2 edits)

i'm with this problem now yet, it must be some problem in the html api routing

(+2)

They fixed it!

(+1)

Wow it works now, thanks for fix it!!!

i had  this problem too. for me, deactivating dps(deep packet inspection) related programs has solved the problem

This topic has been auto-archived and can no longer be posted in because there haven't been any posts in a while.