Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Bug when opening the Files menu?

A topic by Jay created 6 days ago Views: 69 Replies: 4
Viewing posts 1 to 3
(2 edits)

Finally playing the 0.5 update, and boy. Oh boy. I don't even know where to start, the amount of work you put into this game staggers me. My cap is perpetually doffed in your direction.

Of course, I want to read everything, but I've found a little bug that prevents me from reading documents I find in the valley or… *ahem* receive from other sources. When I try to open the Files menu I get an AttributeError'inventory' object has no attribute 'showContracts':

I'm sorry, but an uncaught exception occurred.
While running game code:
  File "renpy/common/00gamemenu.rpy", line 173, in script
    $ ui.interact()
  File "renpy/common/00gamemenu.rpy", line 173, in <module>
    $ ui.interact()
  File "game/files.rpy", line 6, in execute
    screen mobileFilesMenu():
  File "game/files.rpy", line 6, in execute
    screen mobileFilesMenu():
  File "game/files.rpy", line 16, in execute
    if main_menu:
  File "game/files.rpy", line 28, in execute
    default showContracts = inventory.showContracts
  File "game/files.rpy", line 28, in <module>
    default showContracts = inventory.showContracts
AttributeError: 'Inventory' object has no attribute 'showContracts'
[Traceback trimmed]
Darwin-20.5.0-x86_64-i386-64bit
Ren'Py 7.4.6.1693
Minotaur Hotel 0.5.1

As you can see, I'm running the 0.5.1 build on macOS.  Updated from the previous version through Itch.io. I've tried starting from a new save, but I still can't access the Files menu.

Can also see that the Inventory class has a showContracts attribute… my blind guess is the (global?) inventory isn't initialised, for some reason? But everything I know about Python could be written on a postcard, so wouldn't know where to start debugging. (Other than just experimenting by setting them all to true and possibly breaking my build more…)

Developer

Hello Jay! Sorry you had to encounter that, but thank you very much for reporting it. I'm assuming that since you wrote "finally got around to playing 0.5" you're using an old save from 0.4.1?

I did my best to avoid compatibility issues with old versions but that one may have slipped. This is the first time I've heard of this bug, so let me know just in case so I can find out how to replicate it. 

(1 edit)

Good question! I tried from a fresh game, but unfortunately get the same error. That said, I'm not familiar with Ren'Py or how Itch.io does updates; is it possible there are some other settings/files left over from the previous version aside from save files? Happy to try a reinstall from scratch…

Quick update, however: reading the code, I could see you use a different object (persistent) if Files is accessed from the main menu. I gave it a try and that works just fine. Though I can't see some documents I expected, e.g. the testimonies from the trial that you find/are given; unsure if those are specific to the save or just stored somewhere else.

(Also, totally separate—the proofreading you did for this game is exceptional, so in several thousand words of text I only found a couple of really minor typos. Early on, looking for the wine: "Off to the side, there's a glass case containing a a jagged purple rock…". And after your little wrestling match: "MC: Hello, he-who-stil-won't-use-my-name.")

Developer(+1)

Cool then, I'll get this and the typos fixed on the next release, thank you for pointing it out. 

And thank you, we have multiple proofreaders and editors and they're very thorough. Especially Nemo, who wrote most of the ruthless route. Don't hesitate to bring up more issues if you find them!

Oh man—thank you for the reminder that there's soooo much great content waiting on the Ruthless route when I have the time and stomach for it! 馃檶