Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Won't run on OSX

A topic by Almo created Oct 21, 2017 Views: 2,228 Replies: 7
Viewing posts 1 to 6

Complains about not having access to its location, and that I should put it on the Desktop. I have chmod 777 both the app and the folder it's in, and it still doesn't work. From the desktop doesn't work, either.

This is OSX 10.12.6.

I was going to post the same thing – I'm having this very issue on OSX 10.13, even though I tried opening the game on locations where I most definitely have write access (desktop, my home folder's Applications folder). I also tried expanding the downloaded .zip file via both OSX's default tool (Archive Utility) and The Unarchiver, just in case. Finally, I tried opening it from an exFAT formatted external disk, and in that case I got a different error – "Exception: Couldn't find file '._scripts.rpi'." (I can post the full stack trace if you want).

Regarding the "requires write access" error: clicking on "settings" -> "Main Menu" allows us to start a game, despite having this issue. However, when the game tries to create files outside of its container, an exception gets thrown. I managed to go quite far, but got to a point where an exception is thrown whatever I do, so I'm stuck.

Might this error have something to do with System Integrity Protection? You can't modify anything in /System/bin/sbin, or /usrbecause of that feature.

If there's any extra info you'd like to have to help fix this just let me know, I'd be happy to help.

Developer(+1)

It's an issue with Gatekeeper. I've seen success by copying the application out of its folder and putting it directly on the desktop, but if that doesn't work then you may need to look up Gatekeeper disable methods or workarounds.

(+1)

Color me surprised… I had moved the game's folder to the desktop, which didn't fix the issue, but moving the app itself from its folder to the desktop did fix it. Never even considered this might be the issue. Thank you!

Hey, just a note to say thanks for supporting OSX. I've not completed my first playthrough yet, but so far it is a very intriguing game. Well-made too... I did not expect to see actual good poetry in it. Great job!

Just pulling it outside its folder worked. When I tried on the Desktop, I still had it inside its folder. So I now have it in /Volumes/HardDisk/Games/DDLC.app and it's working. Thanks.

Hey! Im having some of the same problems, I have OSX 10.8 and neither ArchiveUnity and Unarchiver worked, although Unarchiver got me farther than archiveunity. It might just be a problem with my program but it wont open the file, which says it a zip file. 

It keeps saying the administer didn't allow this and what do i do?