🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Linux help: if you have audio issues

A topic by Tyrus created 61 days ago Views: 14
Viewing posts 1 to 1
Developer (Edited 2 times)

Cloudbase Prime mostly works great on Linux, especially when the itch app helpfully warns you about any missing dependencies.  Most of its dependencies are probably already installed or they're obvious enough that you'll be able to google them to get going.

BUT there's a tricky pulseaudio issue that may mess up your sound playback: The version of Unity used by Cloudbase Prime assumes pulseaudio is installed if it finds libpulse-simple.so.0 on your system. If that's not actually the case, then it will fail to play sounds in horrible, game-breaking ways.

The easiest fix for this is to simply install the 32-bit version of pulseaudio by typing this into terminal:
sudo apt-get install pulseaudio:i386

You may need to reboot your machine or mess around with pulseaudio --start if things don't work immediately, but they probably will work immediately!