Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Steel Gear

A re-creation and re-imagining of the NES/MSX version of Metal Gear · By clintmich

Weirdness, possibly a bug...

A topic by generalgenius created Jun 16, 2021 Views: 66 Replies: 3
Viewing posts 1 to 3

Alright, I cued up Steel Gear once again. The run-through went like normal, until I started noticing weird things happening.

First, in Building 2, I was able to move through some steel drums and a crate in the room on the right-hand side of the building near the sludge pool. OK, whatever, it's a minor graphical glitch in an out-of-the-way part of the building, so no biggie.

Then I was able to use the ladder for the walkway around the sludge pool to actually get on top of the walkway, surprisingly. I got back down to the floor surface, things seemed to go like normal again.

Then once I got card 8, I went back to the beginning area to open up that storehouse and build up my ammo reserves. There, I started noticing that as I was killing guards around the storehouse with the sniper rifle, they weren't always doing the "!" thing as they died. Even weirder, sometimes they'd do it *after* they died, once even when there was just a bloodstain on the ground. The alert music continued while I went back into the storehouse, then came back out, and didn't revert to the normal music until I killed another guard. Weird, things are seeming gradually glitchier as time goes on, but it's still generally going OK.

Then I got to the supercomputer room, entered the code to Steel Gear, that door opened up, cool. While I was in there, I wanted to use the console, so I tried hitting the "0" key; nothing happened. Tried several times, still nothing. OK, whatever, I didn't really have  a pressing need to use the console. So I went ahead and destroyed Steel Gear, the countdown started, I headed into the room with the Big Boss in it, but for some reason while the cutscene was playing, I was idly pushing keys on the keyboard waiting for the cutscene to end, when I noticed the sound effects for firing the sniper rifle, and opening/closing the door. As if I was actually moving the character around, though I couldn't see what exactly it was doing since the cutscene was still going. Then once the cutscene ended, the game window went completely black, though the music and sound effects continued just as if I was playing the game (including the sfx being timed with keypresses), but I just couldn't see anything, it was completely black. So I had to quit the game at that point.

Sorry for the wall of text, but I really have no idea what went wrong this time. Maybe some kind of working memory corruption or something? I don't know what could cause the game to get gradually glitchier like that. If you need more info, please let me know and I'll add whatever I can to help you figure this out.

I will look into these thanks. Also the "0" cheats are disabled during endgame. That's why it wouldn't work for you. You can still cheat through the Super Computer though.

(1 edit)

I went through and fixed a bunch of stuff you mentioned. Still on the hunt for those boxes and barrels you walked through.

The "!" showing up late was happening on one hit kills because the kill happens so fast the code is late firing. I think I have it fixed now.

I enlarged the blockers around the sludge/sewage pools so the player can't get over them no matter what now. Also I re-enabled the cheats for the endgame bosses, and fixed the player still being under control during those cut scenes. Pressing buttons during the cut scene must have broke the code or something. All controls are now disabled during the cinematic now, and it should fix the black screen as well.

Thanks for reaching out with your finds. Cheers!

(3 edits)

Cool, thanks for the info and fixes. Regarding the boxes and barrels I walked through, they were located in the northeast corner of the room, to the right of the prisoner cell. It's the one room before the pipe structure/barrier at the end of the walkway on the right hand/eastern side of the pool.

As for the "0" key in the supercomputer room, if that's meant to be disabled that's fine with me; this is your remake that you're making after all. Anything that doesn't fit with your vision of how to remake it, and that isn't a bug, probably doesn't need to be included. The final decision is up to you, I'd say.

Just thought of something else: randomly, in any location, it seems like the player character will sometimes appear to be walking on air, not directly on the floor/ground. I know it's kinda hard to see when it happens given the top-down view, and I haven't noticed any one action or event that causes it, and it goes back to normal eventually, but it's probably something to take note of and see what might be causing that to happen. 

Alright, that's it for now. Thanks again!