Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Born of Bread

Fun and quirky turn-based RPG in which you play as a small bread person! · By WildArts Games

Non-Official BoB Demo Bugs/Errors/Comments Post

A topic by Heroic_Teddy created May 03, 2021 Views: 448 Replies: 6
Viewing posts 1 to 3
(1 edit) (+2)

Howdy WildArts!

I know there is a survey, which I did fill out, I figured some folks might have picture evidence or might have found similar or different bugs, but wasn't able to put it in the survery! Anyway, just thought I'd attempt at making a post to help compile them all into one place! :)

Let me start off by stating in no way whatsoever am I some sort of Game-Tester/Game Designer, rather I'm just a simple gamer who loves Paper Mario. I've also never left feedback on a demo/report bugs, etc. this is my first time, and I haven't a clue what may be considered simple bugs, complicated bugs, so I just thought I'd put out all I found regardless what they may be. I felt compelled to purely out of the passion of wanting to help contribute feedback so that you guys can make the best game possible! That being said, this is what I encountered:

Text Box cut-off: This only happened a few times, but the dialogue box near the bottom would cut off a bit of the text.

The second was being locked into a jumping animation/pose. The fence next to the tree hut to the right in the picture is where this kept happening at, and it was the only place to make this occurrence.


The area to the Vase Boss area was  cursed for me! XD In the first picture, Lint got stuck in the stairs behind Loaf and I got locked into this cutscene where Lint is suppose to talk.


The second time I loaded up, after talking to the Rockgoons Riff and Raff, Lint got stuck in the dialogue box, but it allowed me to get close and personal with their boss, Trash. I couldn't tell you what triggered it. At first I thought it was choosing the option "They're lame!" but it did it for both options after first encountering Riff and Raff. My only, albeit a goofy guess, is that this seemed to only happen whenever I was mashing the button to get through the text again after the first crash.



And this last one was after the Vase Boss. I wish I had a way of capturing footage when it happened, but as I defeated the smaller enemies in the Vase Boss, the last one was the wasp enemy. When the battle was done, the buzzing sound of the wasp enemy was still going during the cutscene in talking with Trash, Riff and Raff. Afterwards, I couldn't take a step without running into an enemy; the problem is that there were no enemies on the field.  I killed the first one, but again, kept running into enemies. One of the battles had an invisible enemy-


When I finally chose to flee, it showed a wasp enemy that had previously been invisible and was finally able to leave the area. Not sure what fixed it aside from fleeing, but glad it did. After I beat the Vase Boss, I noticed the Quest didn't update me destroying the vase, but I still got the keys and was able to finish the demo.

Saving:
- I admit I'm not too sure how the save system is suppose to work. I presume it's aim is to be like Paper Mario and wherever you saved last is where you'll spawn when you start the game/get a game over. When you spawned, you seemed to spawn in the area you last entered, be it the mines, the town, the wilderness. In addition, also, my weapons were unequipped after each reboot.

-Another issue is that despite saving with Dub, nothing seemed to saved?  In one instance I had died, but I realized I hadn't saved since I first could in Lapwing town. However, I spawned near the beginning of Lapwing town, and I saw I still had all my boons? Despite being equipped, they acted as if they weren't, but once I equipped them again, they worked. What threw me for a loop however is when I booted up the demo the next day as I noticed all my boons were gone. At this point, I had already restored the power to the mines, and saw the quests I completed were mixed. Some acted as if I completed them, others acted as if I started them but didn't progress them. 

I'm not sure if I broke the sequence since I had already completed the quests, but I just went to solve each problem right away again to obtain the boons and none of the quests seemed to be fulfilled. For example, the Badgers that are locked out of their home, I flew over the gate to talk to their friend inside. He gave me the same dialogue as before, but this time the gate didn't open to come back out? I had to jump on the rock to hop back over the fence. I then talked to the Badgers again to see if it would trigger the quest anew, but it didn't. I then went to test this with a couple other quests.

The one sister bird looking for her brother, I went straight up to the brother, to which he said he was hiding. I went to talk to the sister, to which she made the dialogue as if I already completed it, but again, no boon. All the quests didn't seem to work unless I started a new game and I'm not sure if the quests is messed up or the saving issue jumbled it all up, but thought I'd bring it up under the saving category.

Controls:
-This may have just been me, but I'll put it out there--- the game controlled well, so long as it worked with my controller. The first time, I used the a wireless xbox one controller and it worked just fine without a hitch. Then the next day, it wouldn't connect whatsoever. Sometimes it worked, other times it didn't. The times it didn't, I immediately went to test another game and it worked just fine?

-The second controller issue is a perplexing one to me. I tested out my Nintendo Switch Pro Controller via Steam's big picture mode since the XBONE controller was hit and miss. It worked wonderfully in the overworld without a hitch, but there were a few instances where the left stick wouldn't register the "left" option, primarily in battle. Here's what I encountered that worked on the XBONE controller and Keyboard, but not the Pro Controller:

                     *I couldn't select to the left through the battle menu.

                     *Lint's Research attack (I'm blanking on the attack name!) was broken. It has you hold to the left, but it wouldn't register whatsoever? However---- it had no problem detecting the left movement for Loaf's Sickle and Pick-axe attack, which have you use the left?

Miscellaneous:
-When on the options menu, you couldn't have resolution, display, or performance selected if you wanted to get out of the tab. You had to go all the down to the V-Sync/Exit Game for the Left Bumper to work again. Also, V-Sync never stayed check?

And that's all I could find for the moment, but I need to state this--- you guys got something incredibly special here! Even if bugs slowed me down the end of the demo, it didn't discourage me from reloading the game and trying again. You created a world I wanted to explore, you created an experience that left me smiling. Often I found myself saying, "Oh that's neat! I like that!" The combat had me excited for future weapons, future buddies and their abilities. I want to know the story, I want to know the characters, I want to see the world, you all left me wanting more!!! :D

Have I any suggestions? The only one I have is a Music Volume button, because the music was quite loud, but that being said--- the music was phenomenal. I can't wait to hear the remaining scores!

Congratulations on all the work so hard! The heart and soul is there, now it just needs a few minor adjustments and I know you guys got this!

Edit: I realized IMMEDIATELY after I posted this, that it wasn't under the Demo feedback tab, which I thought I did.... I apologize!

Thank you for being thorough! Just give so background info: uncompleted quests won't be saved and will reset when you boot the game back up, while completed quests are correctly saved. It was a shortcut to push the demo on time, but you can expect a fully functional save system in the final game ;)

(+1)

Im having a problem with the Switch Pro Controller, this is the same problem as the other post:
-couldn't select to the left through the battle menu
-Lint's brainstorming attack  was broken, couldn't do anything and whas stuck there...

I don't know if the keybord controls are optimal, so its a bit sad that i can't continue this beautiful looking game. 

will there be a patch for the demo ?

(2 edits) (+1)

If I may suggest---

Just for the few times I needed to do those actions, I would just quickly hit the left arrow on the keyboard, then resume with the Pro Controller! :D I rarely had to do this, if frequency of doing that is a concern!

(+1)

Ho thank you for the advice!! I will be able to continue the demo this way!!!

(+1)

Unfortunately, I don't think we have the time to work on various controller compatibility for the demo. There's still a lot to be done and we don't want to pass too much time on things other than the main game. That being said, you can expect things to work correctly in the final game! ;) We hope you understand and thanks a lot for having tried the demo!

(+1)

Yeah don't worry it's understandable, it's already nice to answer!  I can' t wait to see the next part of this game ! Good luck !
(btw it looks BEAUTIFUL)