🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Random Phantom Inputs

A topic by bteo created 93 days ago Views: 145 Replies: 4
Viewing posts 1 to 2

I'm using your latest demo version to see if my controller works.

  1. Controller: Flysky fs-i6
  2. Connection: FPV Racer Simulator with Dongle Cable for Flysky Esky Radiolink Futaba Remote Controller
  3. Windows 10 x64
  4. I've setup the controller to be in Trainermode. And have tested with Student Mode on and off still the same issue.

The controller works perfect Freerider but at random times while flying it would roll to the left slightly and very hard at times. And then sometimes it just keeps rolling. These inputs are done randomly while flying even straight. Before buying it I need to fix it or there's no point in trying to fly.

Please help!

I've attached a screenshot. The white circles in clibration screen has 1 circle which I cannot control. It is not binded to any of my controller.  I believe this might be causing the problem.


I found that my controller when the throttle or roll is moved to a certain postion (while in the trim setup) the circles on the trim setup is jumping around very far apart. I have to manually move the circle dails on my controller and it will then disappear.

Anyone have this issue or know how to fix it? I've managed to get it working better now while flying I still get random inputs causing me to crash sometimes.

Developer

Hi, I haven't heard of that particular issue before. When you are in the trim setup, it shows the stick input that it's reading. So the jumping you describe is the same that's causing the random input when flying too.

If you aren't experiencing that erratic input when flying for real then I guess there is nothing wrong with the transmitter. Might have something to do with the USB dongle (or USB drivers) perhaps.

I would suggest to try another dongle if possible, or, to try the Smartpropoplus method described in the manual and see if that helps.

I found a solution. Had to disable all my switches on my controller then swtich it to studen mode. That stopped the phantom inputs. Thanks for the reply!

Developer

Great, glad to hear you found the solution! Thanks for sharing, that might be helpful to others who might encounter the same thing.