Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Juice Galaxy (formerly Juice World)

Floppy ragdoll rpg sandbox with physics-based combat · By fishlicka

[Bug] Toilet realm not rendering properly

A topic by froggy98 created Oct 05, 2020 Views: 1,357 Replies: 16
Viewing posts 1 to 13
(+3)

hello gamer,
i tried to explore the depths of the toilet realm but all of the walls are solid black. i have confirmed from on line you tube videos that this is not intended. what can I do about this
I am running the linux version, if that helps.
screenshot included:

(+1)

The linux version seems to be bugged atm.I am having the same problems but rest of the game works fine tho, played through everything except Toilet Realm.

(+1)

YEAA ok good to know it's not just me. Also on Linux and the Toilet Realm is pitch black.

Developer(+2)

Are the fog giants not pitch black? ty for letting me know, sorry I didnt catch this 2 months ago

(1 edit)

hello fishlicka,I have a problem on the toilet realm,I try to enter it and it keeps getting stuck making the caves,I downloaded Windows 32-bit on Windows 7 ultimate,so my hard worked on characters are stuck forever,but if I press esc to get the menu out and press esc again,it summons me and fall in water it the screen is frozen on loading caves,do you know why?

from:core_eater

(+1)

the fog giants are not pitch black

(+1)

I can confirm this is still an issue, using Debian (Sid) Linux. All other parts of the game are entirely playable and don't appear to have any rendering issues except the toilet realm. Fog giants render as expected. 

Still a problem

-linux user

Experienced this today. Took me a while to figure out it wasn't intended, lol.

Arch Linux

(1 edit)

The Windows version works great for me with Wine. Toilet realm renders properly. Running with a 32-bit Wine prefix. I already have some libraries installed in my prefix, so it might not work well in a fresh one. YMMV. But just letting people know that it's possible to run through Wine as a workaround.

If I click out the window, I can't do anything and have to close the game and reopen. Never lost my save doing this, so not a huge problem. This is likely a Wine bug, not the game's fault.

same

fix it 

NOW

(juice.co.uk)

:)

!

hi

Got this problem tonight.  Did a little chasing, it looks like if I run with -force-glcore everything is textured black, if I run with -force vulkan there is no level geometry other than the sgt suckerpunch boss room, some water pools, the starting pipe and some juice fountains.  Other than it's just an endless void.  Maybe someone smarter than me can tweak some opengl / vulkan settings to figure out a workaround?

Developer (1 edit)

Good news! After all this time, this issue should be fixed in the next update!

I would appreciate it if someone who has been experiencing this issue could try out the new test build and let me know if there are any problems. You can get it here:

https://fishlicka.itch.io/juice-galaxy-test / pass: wallbounce

I believe it was caused by a certain shader effect I was using, so I re-wrote it to hopefully be more compatible.

That build fixes the problem for me!  Thanks for the update!

Developer

Awesome, thanks for letting me know!