Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

porta2note

0
Posts
1
Topics
2
Followers
1
Following
A member registered Oct 17, 2017 · View creator page →

Creator of

Recent community posts

Hey,

I set up the game to play with my Thrustmaster T-Flight HOTAS X. For the most part it works great, and is far more fun than a gamepad IMHO, but I'm having a couple issues:

- Initially  my plane barrel-rolled constantly with nothing I could do to stop it. I thought this was a calibration issue, until I realized the mouse was causing it. I'd move the cursor off-screen when the mission started and it would register that as a constant roll input. I did NOT have anything mapped to the mouse at all, I'd gone and cleared all the mouse input bindings beforehand. Ticking the "disable mouse" button fixed this, but that also disabled it in the menus which is a pain.

- I can only get the throttle to register 50%-100% input despite using the entire range of motion. I actually had to map a button to 'throttle down' so that I can throttle back to 0% for landing, etc. I have to keep the button held down or my craft speeds back up. I think this could be fixed with the calibration options, but it seems impossible to set up with the mouse disabled (see above.)

- For some reason pressing 'A' to land (mapped to one of my joystick buttons) is really inconsistent. I can usually get it to work on the carriers if I hammer the button a bunch of times when I'm in the landing zone, but I've never been able to land at a ground airport. This is excaberated by the fact that I have to hold down the 'throttle down' button as I'm passing over the landing strip (see above.) Maybe I'm doing it wrong?

- For that matter, despite the fact that the names of all the buttons show up properly in the 'rebind controls' menu, all the in-game prompts are still labelled as if I was using an Xbox 360 gamepad. ("Press 'A' to land", etc.) This is really confusing sometimes, and actually makes the tutorial impossible as I haven't been able to get it to register an input when it asks me to press LT & RT. I have a joystick axis mapped to do that function rather than buttons. (I'm wondering if landing on an airport is the same issue - could this be hard-wired to an Xbox button input instead of using the configured controller?)

Really enjoying the game so far, so hoping there's a workaround or these issues can be addressed in the next patch! FWIW I'm running Linux Mint 18.3 with the built-in drivers for my joystick+throttle (natively supported.) jstest-gtk reports all buttons & axes responding as normal. Please let me know if there's some way to fix this.