Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

RetroTech

8
Posts
4
Followers
76
Following
A member registered Feb 26, 2018 · View creator page →

Creator of

Recent community posts

Yes I have. Are you sure it's updated? On download page it says it's 3 days old.

Anyway I hope linux/monogame version will work fine (shaders?)

0.1.1 works but 0.2 crashes.

Exception in thread "main" java.lang.NullPointerException

        at mystiqa.game.state.GameState.update(GameState.java:85)
        at mystiqa.game.state.world.WorldState.update(WorldState.java:98)
        at mystiqa.game.Game.render(Game.java:74)
        at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Window.update(Lwjgl3Window.java:386)
        at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.loop(Lwjgl3Application.java:136)
        at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.<init>(Lwjgl3Application.java:110)
        at mystiqa.game.desktop.DesktopLauncher.main(DesktopLauncher.java:16)

v0.2 crashes on windows. Switching to monogame?

It works on Windows

I'm planning to install Win7 on miniPC, probably this weekend 

(2 edits)

0.0.1 works on both machines (but crashes when I get attacked).

2010 laptop: Intel Corporation Core Processor Integrated Graphics Controller

OpenGL version string: 2.1 Mesa 19.0.8
OpenGL shading language version string: 1.20
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 19.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16

2015 miniPC: Intel Corporation Atom Processor Graphics & Display

OpenGL version string: 3.0 Mesa 18.3.6
OpenGL shading language version string: 1.30
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.3.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

It crashes immediately. I tried v.0.1 and v.0.1.1 on two linux machines, Intel gfx, openjdk-8 and openjdk-11 

`Exception in thread "LWJGL Application"

java.lang.IllegalArgumentException: no uniform with name 'cx' in shader`

$ ./px8
thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: "MIDI support not available"', /checkout/src/libcore/result.rs:860:4

how to solve this one?