Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

yup! you need to use an older version of love2d though - this was built using 0.10.2.

Whoo, thanks!