Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

On the main page it lists Distress version 1.5 but the folder I downloaded says 1.2 and when I install the game using the Itch.io app I also get version 1.2. Steam lists a version 1.4 but no version 1.5. In the game itself under the "about" section it says Distress 1.2. Is there any newer version than 1.2 ?

(1 edit) (+1)

Hey PL,

I just checked the branches to make sure and this is the most up-to-date version. They're just not named appropriately. Can't fix it tonight because I don't have the files on the laptop nearby but the naming issue will be resolved this week. However, the version you're playing has the most up-to-date content outside of the name goof. Apologies and thanks for bringing the issue to our attention!