Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

This error is usually caused by not having a driver that supports a sufficient version (or any version) of OpenGL installed. Try installing the latest drivers for your GPU, and if that doesn't work, what GPU or motherboard do you have?

I have found that the GPU that my laptop has, the Intell HD 3000 series, has an issue with openGL on windows 10.(Though Minecraft plays fine) I have to get a new computer to play, or maybe use an old one.

Thank you for your time

Seems like Minecraft works around this by bundling an older version of Java, since the bug is partially related to using JRE 1.8. I've been thinking about downgrading to only requiring JRE 1.7 for the final release, which might fix the problem.

If it'll help, that would be great.