Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Looks awesome!

Didn't work in my office PC which has an Intel Graphics Chip though.

The command prompt reads: "GLSL 1.30 or higher is required."

I will try it on my gaming PC.